package/polkit: enable gobject-introspection support
authorAdam Duskett <Aduskett@gmail.com>
Sat, 18 Apr 2020 02:58:16 +0000 (19:58 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 18 Apr 2020 12:46:48 +0000 (14:46 +0200)
If gobject-introspection is selected, add the gobject-introspection package to
the dependency list and set the conf opt --enable-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/polkit/polkit.mk

index ee0b3674de8d4cf29d450076f8548b14692a1a58..3ae42b2312a06c0a19a51fabd8d26a517b955736 100644 (file)
@@ -26,6 +26,13 @@ POLKIT_CONF_OPTS = \
        --disable-libelogind \
        --disable-libsystemd-login
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+POLKIT_CONF_OPTS += --enable-introspection
+POLKIT_DEPENDENCIES += gobject-introspection
+else
+POLKIT_CONF_OPTS += --disable-introspection
+endif
+
 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
 POLKIT_DEPENDENCIES += linux-pam
 POLKIT_CONF_OPTS += --with-authfw=pam