linux-firmware: add support for intel iwlwifi 7265D
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 19 Apr 2016 14:44:03 +0000 (11:44 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 24 Apr 2016 21:39:01 +0000 (23:39 +0200)
It selects 7265 non-D firmware since they share the same firmware for
old kernel versions (rev 10 D-variant is the same as rev 10 non-D).

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
[Thomas: add a comment about the select in Config.in.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/linux-firmware/Config.in
package/linux-firmware/linux-firmware.mk

index 5a94a3ceb82940f9f9601478b4116b1a7f02add2..b0608856bb1b696d12fdf07fa28e43181dfa058a 100644 (file)
@@ -98,6 +98,15 @@ config BR2_PACKAGE_LINUX_FIRMWARE_IWLWIFI_7265
          Firmware files for the Intel Wifi 7265 devices supported by
          the iwlwifi kernel driver.
 
+config BR2_PACKAGE_LINUX_FIRMWARE_IWLWIFI_7265D
+       bool "Intel iwlwifi 7265D"
+       # needed for old kernel versions, where the non-D and D
+       # firmwares were the same
+       select BR2_PACKAGE_LINUX_FIRMWARE_IWLWIFI_7265
+       help
+         Firmware files for the Intel Wifi 7265D devices supported by
+         the iwlwifi kernel driver.
+
 config BR2_PACKAGE_LINUX_FIRMWARE_LIBERTAS_SD8686_V8
        bool "Libertas SD 8686 v8"
        help
index 2770bd9f2ed773a656daa3666c7b40b0ed2a6c35..532604b80556c76fcdc09880375e59982dd28bb7 100644 (file)
@@ -257,6 +257,11 @@ LINUX_FIRMWARE_FILES += iwlwifi-7265-*.ucode
 LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.iwlwifi_firmware
 endif
 
+ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_IWLWIFI_7265D),y)
+LINUX_FIRMWARE_FILES += iwlwifi-7265D-*.ucode
+LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.iwlwifi_firmware
+endif
+
 ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_BNX2X),y)
 LINUX_FIRMWARE_FILES += \
        bnx2x/bnx2x-e1-7.10.51.0.fw \