package/jitterentropy-library: fix build failure due to missing -fPIC
authorMatt Weber <matthew.weber@rockwellcollins.com>
Fri, 25 Oct 2019 08:16:30 +0000 (03:16 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 25 Oct 2019 14:38:59 +0000 (16:38 +0200)
jitterentropy-library needs -fPIC flag to build so add it when building.

Fixes:
http://autobuild.buildroot.net/results/505/5059207ec9ab0b502717626cc84956dafd0c3c32/

[Original: http://patchwork.ozlabs.org/patch/1182068/]
Cc: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/jitterentropy-library/jitterentropy-library.mk

index 2ea24f83acdc007bb6ca34cb469f5b5d87f4fd7f..70af24e5dbe5b3248856d0c3475f906ae06cd8c2 100644 (file)
@@ -23,7 +23,7 @@ endif
 
 
 define JITTERENTROPY_LIBRARY_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
                $(JITTERENTROPY_LIBRARY_BUILD_TARGETS)
 endef