package/daq: fix parallel build
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 12 Oct 2020 16:19:58 +0000 (18:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 13 Oct 2020 11:23:33 +0000 (13:23 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/daq/0002-parallel-grammar.patch [new file with mode: 0644]
package/daq/daq.mk

diff --git a/package/daq/0002-parallel-grammar.patch b/package/daq/0002-parallel-grammar.patch
new file mode 100644 (file)
index 0000000..ba0e256
--- /dev/null
@@ -0,0 +1,29 @@
+Fix parallel build
+
+https://bugs.gentoo.org/673390
+
+Downloaded from
+https://gitweb.gentoo.org/repo/gentoo.git/tree/net-libs/daq/files/daq-2.0.6-parallel-grammar.patch
+
+Patch was sent upstream: https://seclists.org/snort/2014/q3/1016
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+--- a/sfbpf/Makefile.am
++++ b/sfbpf/Makefile.am
+@@ -43,13 +43,14 @@
+ libsfbpf_la_LDFLAGS = -version-info 0:1:0 @XCCFLAGS@
+ # use of $@ and $< here is a GNU idiom that borks BSD
+-sf_scanner.c: $(srcdir)/scanner.l
++sf_scanner.c: $(srcdir)/scanner.l tokdefs.h
+       @rm -f $(srcdir)/sf_scanner.c
+       $(srcdir)/runlex.sh $(V_LEX) -osf_scanner.c $(srcdir)/scanner.l
+ sf_scanner.o: sf_scanner.c tokdefs.h
+ tokdefs.h: sf_grammar.c
++
+ sf_grammar.c: $(srcdir)/grammar.y
+       @rm -f sf_grammar.c tokdefs.h
+       $(V_YACC) -d $(srcdir)/grammar.y
index f0f996ba2ce76b1f6989a81d6aaa31888c359748..06983c0b6d7fca87d6c66dc0b0fe10bebf0f3231 100644 (file)
@@ -10,10 +10,8 @@ DAQ_LICENSE = GPL-2.0
 DAQ_LICENSE_FILES = COPYING
 DAQ_INSTALL_STAGING = YES
 DAQ_DEPENDENCIES = host-bison host-flex
-
-# package does not build in parallel due to improper make rules
-# related to the generation of the tokdefs.h header file
-DAQ_MAKE = $(MAKE1)
+# 0002-parallel-grammar.patch
+DAQ_AUTORECONF = YES
 
 # disable ipq module as libipq is deprecated
 DAQ_CONF_OPTS += --disable-ipq-module