Add new package apr-util
authorRico Bachmann <bachmann@tofwerk.com>
Thu, 3 May 2012 12:22:36 +0000 (14:22 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 3 May 2012 21:53:24 +0000 (23:53 +0200)
[Peter: BR2_PACKAGE_NEON not LIBNEON]
Signed-off-by: Rico Bachmann <bachmann@tofwerk.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/apr-util/Config.in [new file with mode: 0644]
package/apr-util/apr-util-1.4.1-remove-checkapr.patch [new file with mode: 0644]
package/apr-util/apr-util.mk [new file with mode: 0644]

index ed66c0586ac36084ffb37e13859a9abdb78356f3..caa618b6ac407fd6f15cfd55060bde603b7171d1 100644 (file)
@@ -379,6 +379,7 @@ endmenu
 
 menu "Other"
 source "package/apr/Config.in"
+source "package/apr-util/Config.in"
 source "package/fftw/Config.in"
 source "package/libargtable2/Config.in"
 source "package/argp-standalone/Config.in"
diff --git a/package/apr-util/Config.in b/package/apr-util/Config.in
new file mode 100644 (file)
index 0000000..99b32f2
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_APR_UTIL
+       bool "apr-util"
+       select BR2_PACKAGE_APR
+       select BR2_PACKAGE_SQLITE
+       select BR2_PACKAGE_NEON
+       select BR2_PACKAGE_NEON_ZLIB
+       select BR2_PACKAGE_ZLIB
+       help
+         The utility library for the apache runtime project
+
+         http://apr.apache.org/
diff --git a/package/apr-util/apr-util-1.4.1-remove-checkapr.patch b/package/apr-util/apr-util-1.4.1-remove-checkapr.patch
new file mode 100644 (file)
index 0000000..42ad12f
--- /dev/null
@@ -0,0 +1,21 @@
+remove check apr
+
+this patch removes the check of apr which fails the build
+
+Signed-off-by: Rico Bachmann <bachmann-ahF9wiJNQgNBDgjK7y7TUQ@public.gmane.org>
+---
+v1: disable the check for APU_FIND_APR because the check only looks into folders
+named apr, and our source-tree is called apr-versionnumber (e.g. apr-1.4.6)
+
+diff -rupN apr-util-1.4.1/configure.in apr-util-1.4.1-fix/configure.in
+--- apr-util-1.4.1/configure.in        2009-12-17 20:15:19.000000000 +0100
++++ apr-util-1.4.1-fix/configure.in    2012-04-24 10:10:32.000000000 +0200
+@@ -99,7 +99,7 @@ fi
+ dnl
+ dnl Find the APR includes directory and (possibly) the source (base) dir.
+ dnl
+-APU_FIND_APR
++dnl APU_FIND_APR
+ dnl
+ dnl even though we use apr_rules.mk for building apr-util, we need
diff --git a/package/apr-util/apr-util.mk b/package/apr-util/apr-util.mk
new file mode 100644 (file)
index 0000000..564b1bb
--- /dev/null
@@ -0,0 +1,13 @@
+#############################################################
+#
+# apr-util
+#
+#############################################################
+APR_UTIL_VERSION = 1.4.1
+APR_UTIL_SITE = http://archive.apache.org/dist/apr
+APR_UTIL_INSTALL_STAGING = YES
+APR_UTIL_DEPENDENCIES = apr sqlite neon zlib
+APR_UTIL_CONF_OPT = \
+       --with-apr=$(BUILD_DIR)/apr-$(APR_VERSION) \
+
+$(eval $(call AUTOTARGETS))