cairo: Add tee surface backend option (required by firefox)
authorStefan Froberg <stefan.froberg@petroprogram.com>
Sat, 11 Aug 2012 21:57:11 +0000 (00:57 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Aug 2012 16:29:45 +0000 (18:29 +0200)
Signed-off-by: Stefan Froberg <stefan.froberg@petroprogram.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cairo/Config.in
package/cairo/cairo.mk

index 19c47231dd0860f7172aaf9cf3930b0ba3cb0b43..398e47fb6c060f96790f0f6683be88e5fa1d52cd 100644 (file)
@@ -32,4 +32,7 @@ config BR2_PACKAGE_CAIRO_SVG
        select BR2_PACKAGE_CAIRO_PNG
        select BR2_PACKAGE_CAIRO_PDF
 
+config BR2_PACKAGE_CAIRO_TEE
+       bool "tee support"
 endif
+
index 6b456dd89dd0d0cc8b2898aef65827c546527d4b..eedb28d0e4f8e8c6380cb1a4c1ec9dd295af9c04 100644 (file)
@@ -77,4 +77,10 @@ else
        CAIRO_CONF_OPT += --disable-svg
 endif
 
+ifeq ($(BR2_PACKAGE_CAIRO_TEE),y)
+       CAIRO_CONF_OPT += --enable-tee
+else
+       CAIRO_CONF_OPT += --disable-tee
+endif
+
 $(eval $(autotools-package))