package/gesftpserver: fix build without Python
authorAndreas Naumann <anaumann@ultratronik.de>
Thu, 24 Jun 2021 12:32:37 +0000 (14:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Jun 2021 13:03:16 +0000 (15:03 +0200)
The build of gesftserver in an environment without Python fails with:

checking for Python 2.4 or better... configure: error: cannot find Python 2.4 or better

However, it turns out that Python is only needed for tests, which we
don't run/use in Buildroot, so we can safely build gesftpserver
without Python.

Signed-off-by: Andreas Naumann <anaumann@ultratronik.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gesftpserver/gesftpserver.mk

index 85511a3c976897b6f1e2e93a8608e4f37686a216..20ad92d25a1d6cf4353af22d266cf0694dad4ffd 100644 (file)
@@ -23,6 +23,10 @@ GESFTPSERVER_DEPENDENCIES += \
        $(if $(BR2_ENABLE_LOCALE),,libiconv) \
        $(if $(BR2_PACKAGE_OPENSSH),openssh)
 
+# Python on the host is only used for tests, which we don't use in
+# Buildroot
+GESFTPSERVER_CONF_ENV += rjk_cv_python24=false
+
 # openssh/dropbear looks here
 define GESFTPSERVER_ADD_SYMLINK
        ln -sf gesftpserver $(TARGET_DIR)/usr/libexec/sftp-server