Get rid of useless OpenMP related code
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Apr 2010 21:46:54 +0000 (23:46 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 11 Apr 2010 19:10:35 +0000 (21:10 +0200)
It seems that there was an intention to add BR2_ENABLE_OPENMP someday,
but it was in June 2007 (commit
c81807a9d71fba9f35eeb7e3f3b56bda4b2e0edd) and since then, nothing
occured. Therefore, get rid of this code, and just pass
--disable-openmp to gettext to keep the current behaviour.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gettext/gettext.mk
toolchain/Makefile.in

index 5b045603c29a36e74afe69251193618e1704289b..8ec8bdfcb9b54e811ce610429ed52df3878787dd 100644 (file)
@@ -93,7 +93,7 @@ $(GETTEXT_DIR)/.configured: $(GETTEXT_DIR)/.unpacked
                --disable-libasprintf \
                --enable-shared \
                $(IGNORE_EXTERNAL_GETTEXT) \
-               $(OPENMP) \
+               --disable-openmp \
        )
        touch $@
 
index 16451ee736ba784087391199ab20dda28b124311..91aa17af619e3e811095a448db9d3ea2112d4676 100644 (file)
@@ -10,13 +10,6 @@ else
 MULTILIB:=--disable-multilib
 endif
 
-ifeq ($(BR2_ENABLE_OPENMP),y)
-OPENMP:=--enable-openmp
-else
-OPENMP:=--disable-openmp
-endif
-
-
 ifeq ($(BR2_TOOLCHAIN_SYSROOT),y)
 BR2_SYSROOT_PREFIX=# nothing, straight into /usr
 BR2_SYSROOT_STAGING_DESTDIR=DESTDIR=$(STAGING_DIR)/