jamvm: bump to 2.0.0 (including mips big-endian support)
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Fri, 26 Sep 2014 19:36:43 +0000 (21:36 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 27 Sep 2014 07:42:42 +0000 (09:42 +0200)
This commit bumps jamvm to version 2.0.0. From the release notes:

    I'm pleased to announce a new release of JamVM.  JamVM 2.0.0 is the
    first release of JamVM with support for OpenJDK (in addition to GNU
    Classpath). Although IcedTea already includes JamVM with OpenJDK
    support, this has been based on periodic snapshots of the development
    tree.

    JamVM 2.0.0 supports OpenJDK 6, 7 and 8 (the latest). With OpenJDK 7 and
    8 this includes full support for JSR 292 (invokedynamic). JamVM 2.0.0
    with OpenJDK 8 also includes full support for Lambda expressions (JSR
    335), type annotations (JSR 308) and method parameter reflection.

    In addition to OpenJDK support, JamVM 2.0.0 also includes many
    bug-fixes, performance improvements and improved compatibility (from
    running the OpenJDK jtreg tests).

As this release now also supports MIPS big-endian targets, this commit
fixes bug #7010 (https://bugs.busybox.net/show_bug.cgi?id=7010)

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/jamvm/Config.in
package/jamvm/jamvm.mk

index dbd0fbbd3e1c82fd0b6f826f7cc329e46f40ef9e..f4809957cf2cbbef4ce17e0d7a6d4a4c0a5e8c72 100644 (file)
@@ -1,8 +1,8 @@
 config BR2_PACKAGE_JAMVM
        bool "jamvm"
        depends on BR2_INET_IPV6
-       depends on BR2_arm || BR2_armeb || BR2_i386 \
-               || BR2_mipsel || BR2_powerpc || BR2_x86_64
+       depends on BR2_arm || BR2_armeb || BR2_i386 || BR2_x86_64 \
+               || BR2_mips || BR2_mipsel || BR2_powerpc
        select BR2_PACKAGE_ZLIB
        select BR2_PACKAGE_CLASSPATH
        help
@@ -12,6 +12,6 @@ config BR2_PACKAGE_JAMVM
          http://jamvm.sf.net
 
 comment "jamvm needs a toolchain w/ IPv6"
-       depends on BR2_arm || BR2_armeb || BR2_i386 \
-               || BR2_mipsel || BR2_powerpc || BR2_x86_64
+       depends on BR2_arm || BR2_armeb || BR2_i386 || BR2_x86_64 \
+               || BR2_mips || BR2_mipsel || BR2_powerpc
        depends on !BR2_INET_IPV6
index 53455c48a03d2e387242b4bb63a044ad84d436e8..a2db513f61237cadc30f24b590f7500744dd82f7 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-JAMVM_VERSION = 1.5.4
+JAMVM_VERSION = 2.0.0
 JAMVM_SITE = http://downloads.sourceforge.net/project/jamvm/jamvm/JamVM%20$(JAMVM_VERSION)
 JAMVM_LICENSE = GPLv2+
 JAMVM_LICENSE_FILES = COPYING