fs/iso9660: use install instead of cp
authorGuido Martínez <guido@vanguardiasur.com.ar>
Fri, 21 Nov 2014 16:19:08 +0000 (13:19 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Nov 2014 18:01:27 +0000 (19:01 +0100)
This way we don't depend on the permissions of files under boot/ or fs/,
which aren't tracked.

While we're at it, change all 'cp' usages into 'install' with the
correct mode for each file.

Signed-off-by: Guido Martínez <guido@vanguardiasur.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
fs/iso9660/iso9660.mk

index 908f0e981ebac16d4e60720867f85c402cd57d0e..5b44ba42413c3079506e44ebfe5457be2a5f723d 100644 (file)
@@ -14,20 +14,22 @@ ROOTFS_ISO9660_DEPENDENCIES = grub host-cdrkit host-fakeroot linux rootfs-cpio
 
 $(BINARIES_DIR)/rootfs.iso9660: $(ROOTFS_ISO9660_DEPENDENCIES)
        @$(call MESSAGE,"Generating root filesystem image rootfs.iso9660")
-       mkdir -p $(ISO9660_TARGET_DIR)
-       mkdir -p $(ISO9660_TARGET_DIR)/boot/grub
-       cp $(GRUB_DIR)/stage2/stage2_eltorito $(ISO9660_TARGET_DIR)/boot/grub/
-       cp $(ISO9660_BOOT_MENU) $(ISO9660_TARGET_DIR)/boot/grub/menu.lst
+       $(INSTALL) -D -m 0644 $(GRUB_DIR)/stage2/stage2_eltorito \
+               $(ISO9660_TARGET_DIR)/boot/grub/stage2_eltorito
+       $(INSTALL) -D -m 0644 $(ISO9660_BOOT_MENU) \
+               $(ISO9660_TARGET_DIR)/boot/grub/menu.lst
 ifeq ($(BR2_TARGET_GRUB_SPLASH),)
        $(SED) '/^splashimage/d' $(ISO9660_TARGET_DIR)/boot/grub/menu.lst
 else
-       cp boot/grub/splash.xpm.gz $(ISO9660_TARGET_DIR)/
+       $(INSTALL) -D -m 0644 boot/grub/splash.xpm.gz \
+               $(ISO9660_TARGET_DIR)/splash.xpm.gz
 endif
-       cp $(LINUX_IMAGE_PATH) $(ISO9660_TARGET_DIR)/kernel
+       $(INSTALL) -D -m 0644 $(LINUX_IMAGE_PATH) $(ISO9660_TARGET_DIR)/kernel
 ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
        $(SED) '/initrd/d'  $(ISO9660_TARGET_DIR)/boot/grub/menu.lst
 else
-       cp $(BINARIES_DIR)/rootfs.cpio$(ROOTFS_CPIO_COMPRESS_EXT) $(ISO9660_TARGET_DIR)/initrd
+       $(INSTALL) -D -m 0644 $(BINARIES_DIR)/rootfs.cpio$(ROOTFS_CPIO_COMPRESS_EXT) \
+               $(ISO9660_TARGET_DIR)/initrd
 endif
        # Use fakeroot to pretend all target binaries are owned by root
        rm -f $(FAKEROOT_SCRIPT)