perl-dist-checkconflicts: new package
authorChristopher McCrory <chrismcc@gmail.com>
Mon, 20 Aug 2018 11:55:08 +0000 (04:55 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 12 Sep 2018 20:54:10 +0000 (22:54 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-dist-checkconflicts/Config.in [new file with mode: 0644]
package/perl-dist-checkconflicts/perl-dist-checkconflicts.hash [new file with mode: 0644]
package/perl-dist-checkconflicts/perl-dist-checkconflicts.mk [new file with mode: 0644]

index e454149002ef99784a916839f5bf65c42015c369..06df040b842bf71ce15ab77f3d3b0f3eb82e4b53 100644 (file)
@@ -496,6 +496,7 @@ F:  package/perl-date-manip/
 F:     package/perl-dbd-mysql/
 F:     package/perl-dbi/
 F:     package/perl-device-serialport/
+F:     package/perl-dist-checkconflicts/
 F:     package/perl-file-slurp/
 F:     package/perl-io-interface/
 F:     package/perl-io-socket-multicast/
index 3faffca2716e446bc067471dee8bb6d53551eb77..8b710ef1e885c020b2f05a61787c0c2bf9d2feff 100644 (file)
@@ -685,6 +685,7 @@ menu "Perl libraries/modules"
        source "package/perl-digest-hmac/Config.in"
        source "package/perl-digest-md5/Config.in"
        source "package/perl-digest-sha1/Config.in"
+       source "package/perl-dist-checkconflicts/Config.in"
        source "package/perl-encode-detect/Config.in"
        source "package/perl-encode-locale/Config.in"
        source "package/perl-file-listing/Config.in"
diff --git a/package/perl-dist-checkconflicts/Config.in b/package/perl-dist-checkconflicts/Config.in
new file mode 100644 (file)
index 0000000..10f0944
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PERL_DIST_CHECKCONFLICTS
+       bool "perl-dist-checkconflicts"
+       select BR2_PACKAGE_PERL_MODULE_RUNTIME
+       help
+         declare version conflicts for your dist
+
+         http://metacpan.org/release/Dist-CheckConflicts
diff --git a/package/perl-dist-checkconflicts/perl-dist-checkconflicts.hash b/package/perl-dist-checkconflicts/perl-dist-checkconflicts.hash
new file mode 100644 (file)
index 0000000..5605fed
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    c8725a92b9169708b0f63036812070f2 Dist-CheckConflicts-0.11.tar.gz
+sha256 ea844b9686c94d666d9d444321d764490b2cde2f985c4165b4c2c77665caedc4 Dist-CheckConflicts-0.11.tar.gz
+
+# computed by scancpan
+sha256 b4e0637ed96008ddcbf7e0ddeb73967df3d0b4dc62a6b7fdb86eac37018cb12e LICENSE
diff --git a/package/perl-dist-checkconflicts/perl-dist-checkconflicts.mk b/package/perl-dist-checkconflicts/perl-dist-checkconflicts.mk
new file mode 100644 (file)
index 0000000..4242b50
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-dist-checkconflicts
+#
+################################################################################
+
+PERL_DIST_CHECKCONFLICTS_VERSION = 0.11
+PERL_DIST_CHECKCONFLICTS_SOURCE = Dist-CheckConflicts-$(PERL_DIST_CHECKCONFLICTS_VERSION).tar.gz
+PERL_DIST_CHECKCONFLICTS_SITE = $(BR2_CPAN_MIRROR)/authors/id/D/DO/DOY
+PERL_DIST_CHECKCONFLICTS_DEPENDENCIES = perl-module-runtime
+PERL_DIST_CHECKCONFLICTS_LICENSE = Artistic or GPL-1.0+
+PERL_DIST_CHECKCONFLICTS_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))