package/cracklib: properly handle BR2_SYSTEM_ENABLE_NLS=y configurations
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 9 May 2019 20:43:40 +0000 (22:43 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 10 May 2019 13:59:43 +0000 (15:59 +0200)
Use the TARGET_NLS_DEPENDENCIES and TARGET_NLS_LIBS variables to
correctly handle BR2_SYSTEM_ENABLE_NLS=y configurations.

Fixes:

  http://autobuild.buildroot.net/results/dda70b5b88c75d36c61fbf1cc5fca16ea8414582/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/cracklib/cracklib.mk

index b9e3dc0d75c5c65e4b5d2795ee15c0e3bd4e1c78..91d510ff3423570d88219c3f5fadb66817641c4a 100644 (file)
@@ -9,7 +9,8 @@ CRACKLIB_SITE = https://github.com/cracklib/cracklib/releases/download/v$(CRACKL
 CRACKLIB_LICENSE = LGPL-2.1
 CRACKLIB_LICENSE_FILES = COPYING.LIB
 CRACKLIB_INSTALL_STAGING = YES
-CRACKLIB_DEPENDENCIES = host-cracklib
+CRACKLIB_DEPENDENCIES = host-cracklib $(TARGET_NLS_DEPENDENCIES)
+CRACKLIB_CONF_ENV = LIBS=$(TARGET_NLS_LIBS)
 
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 CRACKLIB_CONF_OPTS += --with-zlib