package/ca-certificates: fix rebuilds
authorMartin Bark <martin@barkynet.com>
Sat, 16 Jun 2018 22:06:00 +0000 (23:06 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 21 Oct 2018 13:34:46 +0000 (14:34 +0100)
Rebuilding ca-certificates using make ca-certificates-rebuild
caused duplicate certificates to be installed in the target. Its build
system is broken: it doesn't detect that the output file already exists,
and instead of overwriting it, a duplicate is generated under a
different name. The net effect is that all certificates are installed
twice after rebuild.

Fix this by cleaning the build directory before building the package.

Signed-off-by: Martin Bark <martin@barkynet.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/ca-certificates/ca-certificates.mk

index 9685d0e6f0b9624bc3c40fd304b58a84ed9555ee..1df9543e032c06146be9f8cfcd201c2424cbfbd2 100644 (file)
@@ -16,7 +16,7 @@ CA_CERTIFICATES_LICENSE = GPL-2.0+ (script), MPL-2.0 (data)
 CA_CERTIFICATES_LICENSE_FILES = debian/copyright
 
 define CA_CERTIFICATES_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) all
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) clean all
 endef
 
 define CA_CERTIFICATES_INSTALL_TARGET_CMDS