hostapd: supports only the real OpenSSL, not LibreSSL
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 16:45:36 +0000 (18:45 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 19:28:13 +0000 (21:28 +0200)
hostapd will not build with LibreSSL without patches, so let's support
only OpenSSL.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/hostapd/hostapd.mk

index e4ca72df6388e3f0db0040b223e1fae6c3c9b9ed..3f94c8c4b758de55d99d3941819cf7d6a4dc51b3 100644 (file)
@@ -38,8 +38,8 @@ HOSTAPD_LIBS += -lnl-3 -lm -lpthread
 endif
 
 # Try to use openssl if it's already available
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
-HOSTAPD_DEPENDENCIES += openssl
+ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
+HOSTAPD_DEPENDENCIES += libopenssl
 HOSTAPD_LIBS += $(if $(BR2_STATIC_LIBS),-lcrypto -lz)
 HOSTAPD_CONFIG_EDITS += 's/\#\(CONFIG_TLS=openssl\)/\1/'
 else