Needed --disable-werror to get 2.16.mumble build from dying on missing prototypes...
authorManuel Novoa III <mjn3@codepoet.org>
Sat, 30 Apr 2005 21:51:23 +0000 (21:51 -0000)
committerManuel Novoa III <mjn3@codepoet.org>
Sat, 30 Apr 2005 21:51:23 +0000 (21:51 -0000)
toolchain/binutils/binutils.mk

index ef9c3dc0a2ac69b31bfb3b5200cde81706d63c0d..22f66331b8167035756cf16f40196c5970fff224 100644 (file)
@@ -6,6 +6,9 @@
 BINUTILS_VERSION:=$(strip $(subst ",, $(BR2_BINUTILS_VERSION)))
 
 BINUTILS_SITE:=http://ftp.kernel.org/pub/linux/devel/binutils
+ifeq ($(BINUTILS_VERSION),2.16)
+BINUTILS_SITE:=http://ftp.gnu.org/gnu/binutils/
+endif
 ifeq ($(BINUTILS_VERSION),2.15)
 BINUTILS_SITE:=http://ftp.gnu.org/gnu/binutils/
 endif
@@ -46,6 +49,7 @@ $(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
                --target=$(REAL_GNU_TARGET_NAME) \
                $(DISABLE_NLS) \
                $(MULTILIB) \
+               --disable-werror \
                $(SOFT_FLOAT_CONFIG_OPTION) );
        touch $(BINUTILS_DIR1)/.configured
 
@@ -104,6 +108,7 @@ $(BINUTILS_DIR2)/.configured: $(BINUTILS_DIR)/.patched
                --target=$(REAL_GNU_TARGET_NAME) \
                $(DISABLE_NLS) \
                $(MULTILIB) \
+               --disable-werror \
                $(SOFT_FLOAT_CONFIG_OPTION) );
        touch $(BINUTILS_DIR2)/.configured