package/vuejs: bump version to 3.0.5
authorJohan Oudinet <johan.oudinet@gmail.com>
Wed, 20 Jan 2021 14:49:01 +0000 (15:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 21 Jan 2021 21:36:22 +0000 (22:36 +0100)
The vuejs developers have changed the way this package is distributed.
The tarball containing the dist files does not contain anymore the
LICENSE file. The license remains MIT but until it is reintroduced in
the tarball, we have to skip the license file hash verification.

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vuejs/vuejs.hash
package/vuejs/vuejs.mk

index d2b30b8d3436659456fab5440cc30a441d536a22..db4a5bbe3e3c86d91a9e15976d17353b03821c79 100644 (file)
@@ -1,3 +1,2 @@
 # Locally computed
-sha256 7ee4d5e4ec7d44fb9918ecb074ad7701eb0bcb3a840cee3c2924734ef3fd888a v2.6.11.tar.gz
-sha256 17fb24bc303763f3fe1911ee24e5225c7ad59f0e3a5d8123e9b730c100a306a6 LICENSE
+sha256  a69f04bf138af09a956150675151edb9354aeec8bd627c21cbcfa646248214fa  vue-3.0.5.tgz
index f7e197c4afa4e179872624d95070d80b40fd853c..43b45e00b7edd911e7f66c9e73becdeac338cd59 100644 (file)
@@ -4,15 +4,14 @@
 #
 ################################################################################
 
-VUEJS_VERSION = 2.6.11
-VUEJS_SOURCE = v$(VUEJS_VERSION).tar.gz
-VUEJS_SITE = https://github.com/vuejs/vue/archive
+VUEJS_VERSION = 3.0.5
+VUEJS_SOURCE = vue-$(VUEJS_VERSION).tgz
+VUEJS_SITE = https://registry.npmjs.org/vue/-
 VUEJS_LICENSE = MIT
-VUEJS_LICENSE_FILES = LICENSE
 
 # Install .min.js as .js
 define VUEJS_INSTALL_TARGET_CMDS
-       $(INSTALL) -m 644 -D $(@D)/dist/vue.min.js \
+       $(INSTALL) -m 644 -D $(@D)/dist/vue.global.prod.js \
                $(TARGET_DIR)/var/www/vue.js
 endef