gettext: make host gettextize non-interactive
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 3 Apr 2014 13:43:30 +0000 (10:43 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 3 Apr 2014 18:12:35 +0000 (20:12 +0200)
Make the host gettextize tool non-interactive to avoid stalling for user
confirmation when using it to fix up a package.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gettext/gettext.mk

index 748c2a59fdd8f24280593ce9068429c2675339fa..b5efa766d3d54fd0e5abc0e4b71eeee05f0ed7ab 100644 (file)
@@ -57,5 +57,11 @@ endef
 endif
 endif # GETTEXT_TOOLS = n
 
+# Disable interactive confirmation in host gettextize for package fixups
+define HOST_GETTEXT_GETTEXTIZE_CONFIRMATION
+       $(SED) '/read dummy/d' $(HOST_DIR)/usr/bin/gettextize
+endef
+HOST_GETTEXT_POST_INSTALL_HOOKS += HOST_GETTEXT_GETTEXTIZE_CONFIRMATION
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))