e2tools: new package
authorDaniel Nyström <daniel.nystrom@timeterminal.se>
Mon, 6 Jul 2009 14:28:52 +0000 (22:28 +0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Apr 2014 21:43:51 +0000 (23:43 +0200)
E2tools is a simple set of GPL'ed utilities to read, write, and
manipulate files in an ext2/ext3 filesystem.  These utilities access a
filesystem directly using the ext2fs library.

[Thomas: add toolchain dependencies as needed, use full Git hash, use
github helper, add support for host version.]

Signed-off-by: Daniel Nyström <daniel.nystrom@timeterminal.se>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/Config.in.host
package/e2tools/Config.in [new file with mode: 0644]
package/e2tools/Config.in.host [new file with mode: 0644]
package/e2tools/e2tools.mk [new file with mode: 0644]

index b9b77ba49ce05654219c2fd06b3c177b0e3b384b..1361e9f13cf010a3e077015b3c7c2730a98a77d9 100644 (file)
@@ -135,6 +135,7 @@ source "package/cramfs/Config.in"
 source "package/curlftpfs/Config.in"
 source "package/dosfstools/Config.in"
 source "package/e2fsprogs/Config.in"
+source "package/e2tools/Config.in"
 source "package/ecryptfs-utils/Config.in"
 source "package/exfat/Config.in"
 source "package/exfat-utils/Config.in"
index ac6091f568933aeeb4f7a379b8d1755e7820ef84..c6997e9c9a2e35ad938bb5b946d2019281f5e258 100644 (file)
@@ -3,6 +3,7 @@ menu "Host utilities"
 source "package/dfu-util/Config.in.host"
 source "package/dosfstools/Config.in.host"
 source "package/e2fsprogs/Config.in.host"
+source "package/e2tools/Config.in.host"
 source "package/genext2fs/Config.in.host"
 source "package/genimage/Config.in.host"
 source "package/genpart/Config.in.host"
diff --git a/package/e2tools/Config.in b/package/e2tools/Config.in
new file mode 100644 (file)
index 0000000..13e2118
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_E2TOOLS
+       bool "e2tools"
+       select BR2_PACKAGE_E2FSPROGS
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_LARGEFILE # e2fsprogs
+       depends on BR2_USE_WCHAR # e2fsprogs
+       depends on BR2_USE_MMU # e2fsprogs
+       help
+         E2tools is a simple set of GPL'ed utilities to read, write,
+         and manipulate files in an ext2/ext3 filesystem.  These
+         utilities access a filesystem directly using the ext2fs
+         library.
+
+         https://github.com/ndim/e2tools
+
+comment "e2tools needs a toolchain w/ threads, largefile and wchar"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/e2tools/Config.in.host b/package/e2tools/Config.in.host
new file mode 100644 (file)
index 0000000..772262a
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_HOST_E2TOOLS
+       bool "host-e2tools"
+       select BR2_PACKAGE_HOST_E2FSPROGS
+       help
+         E2tools is a simple set of GPL'ed utilities to read, write,
+         and manipulate files in an ext2/ext3 filesystem.  These
+         utilities access a filesystem directly using the ext2fs
+         library.
+
+         https://github.com/ndim/e2tools
diff --git a/package/e2tools/e2tools.mk b/package/e2tools/e2tools.mk
new file mode 100644 (file)
index 0000000..97afcc0
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# e2tools
+#
+################################################################################
+
+E2TOOLS_VERSION = 3158ef18a903ca4a98b8fa220c9fc5c133d8bdf6
+E2TOOLS_SITE = $(call github,ndim,e2tools,$(E2TOOLS_VERSION))
+
+# Source coming from github, no configure included.
+E2TOOLS_AUTORECONF = YES
+E2TOOLS_LICENSE = GPLv2
+E2TOOLS_LICENSE_FILES = COPYING
+E2TOOLS_DEPENDENCIES = e2fsprogs
+E2TOOLS_CONF_ENV = LIBS="-lpthread"
+HOST_E2TOOLS_CONF_ENV = LIBS="-lpthread"
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))