perl-xml-libxml: fix build
authorFrancois Perrad <fperrad@gmail.com>
Tue, 1 Jul 2014 08:18:40 +0000 (10:18 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 1 Jul 2014 13:00:18 +0000 (15:00 +0200)
see http://autobuild.buildroot.net/results/f80/f809c99ce4db80e64ca46865fcd9b75b0dcc1fcd/

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/perl-xml-libxml/perl-xml-libxml-01-Makefile-PL.patch [new file with mode: 0644]
package/perl-xml-libxml/perl-xml-libxml.mk

diff --git a/package/perl-xml-libxml/perl-xml-libxml-01-Makefile-PL.patch b/package/perl-xml-libxml/perl-xml-libxml-01-Makefile-PL.patch
new file mode 100644 (file)
index 0000000..ce2724c
--- /dev/null
@@ -0,0 +1,18 @@
+fake check_lib for cross-compilation
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/Makefile.PL
+===================================================================
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -84,8 +84,7 @@
+ # -------------------------------------------------------------------------- #
+ # -------------------------------------------------------------------------- #
+-use lib qw(inc);
+-use Devel::CheckLib;
++sub check_lib { return 1; }
+ # Prompt the user here for any paths and other configuration
index 60a863391cc4f2b20deaf61eddab64ec90f0b9cb..31ff06e9e512f7513b1646422e5fe651b819f9f3 100644 (file)
@@ -11,4 +11,9 @@ PERL_XML_LIBXML_DEPENDENCIES = perl zlib libxml2 perl-xml-sax perl-xml-namespace
 PERL_XML_LIBXML_LICENSE = Artistic or GPLv1+
 PERL_XML_LIBXML_LICENSE_FILES = LICENSE
 
+PERL_XML_LIBXML_CONF_OPT = \
+       LIBS="-L $(STAGING_DIR)/usr/lib" \
+       INC="-I $(STAGING_DIR)/usr/include/libxml2" \
+       NO_THREADS
+
 $(eval $(perl-package))