gmp/mpfr: force static linking
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 9 Feb 2009 13:01:32 +0000 (13:01 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 9 Feb 2009 13:01:32 +0000 (13:01 -0000)
Patch by Maxim Grigoriev.

GCC 4.3.x would link with the correct shared library versions, but without
any RPATH, so it ended up looking for then in /usr/lib/ at runtime.
This is less than good, as the version there might not be compatible, and
even worse for distributions like Ubuntu, which doesn't install those
libs by default, the build breaks.

Fix it by forcing static linking instead.

package/gmp/gmp.mk
package/mpfr/mpfr.mk

index 111f6068cd88e43d72fcb438b23cb4b644d71c4e..00a92ef12e1034d59577bde919ed8353e40443bd 100644 (file)
@@ -83,7 +83,7 @@ $(GMP_DIR2)/.configured: $(GMP_DIR)/.unpacked
                --prefix="$(GMP_HOST_DIR)" \
                --build=$(GNU_HOST_NAME) \
                --host=$(GNU_HOST_NAME) \
-               --enable-shared \
+               --disable-shared \
                --enable-static \
                $(DISABLE_NLS) \
        )
index 1299ee14816a00144ddbf230b437acbb4ec1df11..51b9fb5ec243c3d96e92502f6c983bdb784d1b4b 100644 (file)
@@ -96,7 +96,7 @@ $(MPFR_DIR2)/.configured: $(MPFR_DIR)/.unpacked $(GMP_HOST_DIR)/lib/$(GMP_HOST_B
                --prefix="$(MPFR_HOST_DIR)" \
                --build=$(GNU_HOST_NAME) \
                --host=$(GNU_HOST_NAME) \
-               --enable-shared \
+               --disable-shared \
                --enable-static \
                --with-gmp=$(GMP_HOST_DIR) \
                $(DISABLE_NLS) \