imx-usb-loader: allow building the target variant
authorVincent Prince <vincent.prince.fr@gmail.com>
Wed, 16 May 2018 09:16:05 +0000 (11:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 19 May 2018 20:41:21 +0000 (22:41 +0200)
Having imx-usb-loader on the target might be useful when you're
building a system that itself will be responsible for booting/flashing
i.MX based devices.

Signed-off-by: Vincent Prince <vincent.prince.fr@gmail.com>
[Thomas:
 - improve commit log
 - fix indentation
 - drop BR2_arm dependency
 - add missing host-pkgconf dependency
 - fix prefix variable to install in $(TARGET_DIR)/usr]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/Config.in
package/imx-usb-loader/Config.in [new file with mode: 0644]
package/imx-usb-loader/imx-usb-loader.mk

index 1d6ddee8ec25f882a0149aab261e93713a6e903d..61210cea36a6032bb2f16ce55091491a9881e783 100644 (file)
@@ -188,6 +188,7 @@ menu "Filesystem and flash utilities"
        source "package/genext2fs/Config.in"
        source "package/genpart/Config.in"
        source "package/genromfs/Config.in"
+       source "package/imx-usb-loader/Config.in"
        source "package/mmc-utils/Config.in"
        source "package/mtd/Config.in"
        source "package/mtools/Config.in"
diff --git a/package/imx-usb-loader/Config.in b/package/imx-usb-loader/Config.in
new file mode 100644 (file)
index 0000000..6f083f3
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_IMX_USB_LOADER
+       bool "imx-usb-loader"
+       select BR2_PACKAGE_LIBUSB
+       help
+         This package contains tools to download and execute code
+         on Freescale i.MX5/i.MX6 and Vybrid SoCs through the
+         Serial Download Protocol.
+
+         https://github.com/boundarydevices/imx_usb_loader
index 946a1f3d55122386d13878ee545ff5cbfd5dd77f..01a654e6cffe70994a29cc53978ff7c8ed597de0 100644 (file)
@@ -8,14 +8,24 @@ IMX_USB_LOADER_VERSION = 7e77787c83288a421080a9bf2f67063931f561be
 IMX_USB_LOADER_SITE = $(call github,boundarydevices,imx_usb_loader,$(IMX_USB_LOADER_VERSION))
 IMX_USB_LOADER_LICENSE = LGPL-2.1+
 IMX_USB_LOADER_LICENSE_FILES = COPYING
+IMX_USB_LOADER_DEPENDENCIES = libusb host-pkgconf
 HOST_IMX_USB_LOADER_DEPENDENCIES = host-libusb host-pkgconf
 
+define IMX_USB_LOADER_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
 define HOST_IMX_USB_LOADER_BUILD_CMDS
        $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D)
 endef
 
+define IMX_USB_LOADER_INSTALL_TARGET_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) prefix=$(TARGET_DIR)/usr install
+endef
+
 define HOST_IMX_USB_LOADER_INSTALL_CMDS
        $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) prefix=$(HOST_DIR) install
 endef
 
+$(eval $(generic-package))
 $(eval $(host-generic-package))