package/kodi: add optional support for bluez5
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 29 Apr 2017 08:37:42 +0000 (10:37 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Apr 2017 10:02:09 +0000 (12:02 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas: add missing dependency on BR2_TOOLCHAIN_HAS_SYNC_4 from
bluez5_utils.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/Config.in
package/kodi/kodi.mk

index 7e1140291e9ea4fa5b6ff8ef878629f90fe7643b..e8efd72bf5e43e43bcdd21989cb127db76dbb91b 100644 (file)
@@ -113,6 +113,15 @@ config BR2_PACKAGE_KODI_AVAHI
          Enable Avahi support.
          Select this if you want Kodi to support Bonjour protocol.
 
+config BR2_PACKAGE_KODI_BLUEZ
+       bool "bluetooth"
+       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_4 # bluez5_utils
+       depends on !BR2_PACKAGE_BLUEZ_UTILS # bluez5_utils
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4 # bluez5_utils
+       select BR2_PACKAGE_BLUEZ5_UTILS
+       help
+           Enable bluetooth support
+
 config BR2_PACKAGE_KODI_DBUS
        bool "dbus"
        select BR2_PACKAGE_DBUS
index c3576657e1f27f9b34ae80afda21260a324c46b2..7341cc39dfbb7ae54d4055744581b2ae89ddd6f0 100644 (file)
@@ -183,6 +183,13 @@ else
 KODI_CONF_OPTS += -DENABLE_CAP=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_KODI_BLUEZ),y)
+KODI_CONF_OPTS += -DENABLE_BLUETOOTH=ON
+KODI_DEPENDENCIES += bluez5_utils
+else
+KODI_CONF_OPTS += -DENABLE_BLUETOOTH=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_KODI_DBUS),y)
 KODI_DEPENDENCIES += dbus
 KODI_CONF_OPTS += -DENABLE_DBUS=ON