package/ibm-sw-tpm2: new package
authorPhilippe Reynes <philippe.reynes@softathome.com>
Fri, 3 Jan 2020 15:16:57 +0000 (16:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 19 Apr 2020 19:37:12 +0000 (21:37 +0200)
This project is an implementation of the TCG TPM 2.0 specification. It
is based on the TPM specification Parts 3 and 4 source code donated by
Microsoft, with additional files to complete the implementation.

Signed-off-by: Philippe Reynes <philippe.reynes@softathome.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/ibm-sw-tpm2/Config.in [new file with mode: 0644]
package/ibm-sw-tpm2/ibm-sw-tpm2.hash [new file with mode: 0644]
package/ibm-sw-tpm2/ibm-sw-tpm2.mk [new file with mode: 0644]

index 4f8a9255ed2fa1d55eeb5ebd19e0ea2f1201f2d0..f56d70dc20deb5d6235154c44d00b8217d7bec46 100644 (file)
@@ -2092,6 +2092,9 @@ F:        package/lttng-tools/
 F:     package/python-ipython/
 F:     package/liburcu/
 
+N:     Philippe Reynes <philippe.reynes@softathome.com>
+F:     package/ibm-sw-tpm2/
+
 N:     Pierre Crokaert <pct@crookies.net>
 F:     board/hardkernel/odroidxu4/
 F:     configs/odroidxu4_defconfig
index 5e72b750eac52a9ec22b90b4af8c375dc0d932e8..afa54f739eabcea30755ed5001ecd230ceb59840 100644 (file)
@@ -2338,6 +2338,7 @@ menu "System tools"
        source "package/ftop/Config.in"
        source "package/getent/Config.in"
        source "package/htop/Config.in"
+       source "package/ibm-sw-tpm2/Config.in"
        source "package/initscripts/Config.in"
        source "package/iotop/Config.in"
        source "package/iprutils/Config.in"
diff --git a/package/ibm-sw-tpm2/Config.in b/package/ibm-sw-tpm2/Config.in
new file mode 100644 (file)
index 0000000..dc56304
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_IBM_SW_TPM2
+       bool "ibm-sw-tpm2"
+       depends on !BR2_STATIC_LIBS # ibm-sw-tpm2
+       select BR2_PACKAGE_OPENSSL
+       # libressl is not supported
+       select BR2_PACKAGE_OPENSSL_FORCE_LIBOPENSSL
+       help
+         This project is an implementation of the TCG TPM 2.0
+         specification. It is based on the TPM specification Parts 3
+         and 4 source code donated by Microsoft, with additional
+         files to complete the implementation.
+
+         https://sourceforge.net/projects/ibmswtpm2/
+
+comment "ibm-sw-tpm2 needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/ibm-sw-tpm2/ibm-sw-tpm2.hash b/package/ibm-sw-tpm2/ibm-sw-tpm2.hash
new file mode 100644 (file)
index 0000000..f57dcbb
--- /dev/null
@@ -0,0 +1,6 @@
+# from https://sourceforge.net/projects/ibmswtpm2/files
+sha1  a2a5335024a2edc1739f08b99e716fa355be627d  ibmtpm1563.tar.gz
+md5  13013612b3a13dc935fefe1a5684179c  ibmtpm1563.tar.gz
+# Locally computed:
+sha256  fc3a17f8315c1f47670764f2384943afc0d3ba1e9a0422dacb08d455733bd1e9  ibmtpm1563.tar.gz
+sha256  dd2d31b560011ea673e197251e710e52669d911367d83cd3cfd018f8ed58bde9  LICENSE
diff --git a/package/ibm-sw-tpm2/ibm-sw-tpm2.mk b/package/ibm-sw-tpm2/ibm-sw-tpm2.mk
new file mode 100644 (file)
index 0000000..5810266
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# ibm-sw-tpm2
+#
+################################################################################
+
+IBM_SW_TPM2_VERSION = 1563
+IBM_SW_TPM2_SOURCE = ibmtpm$(IBM_SW_TPM2_VERSION).tar.gz
+IBM_SW_TPM2_SITE = https://sourceforge.net/projects/ibmswtpm2/files
+IBM_SW_TPM2_LICENSE = BSD-3-Clause
+IBM_SW_TPM2_LICENSE_FILES = LICENSE
+IBM_SW_TPM2_DEPENDENCIES = openssl
+
+define IBM_SW_TPM2_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src $(TARGET_CONFIGURE_OPTS)
+endef
+
+define IBM_SW_TPM2_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src $(TARGET_CONFIGURE_OPTS) install \
+               DESTDIR=$(TARGET_DIR)
+endef
+
+$(eval $(generic-package))