gettext: build libintl unconditionally for uClibc/musl
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 22:11:10 +0000 (00:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 22:13:24 +0000 (00:13 +0200)
Only the initial patches of the gettext series have been applied, and
a bisectability problem has arised: when BR2_SYSTEM_ENABLE_NLS is
disabled, which is the default, gettext no longer builds libintl.

However, since packages have not yet been updated to the new gettext
logic, they still try to link against libintl, because they rely on
BR2_NEEDS_GETTEXT/BR2_NEEDS_GETTEXT_IF_LOCALE, which are true.

So, as a temporary measure, we adjust the gettext package so that it
unconditionally builds libintl for uClibc/musl, even when NLS is
disabled. This commit will be reverted once all packages have been
fixed.

Fixes:

  http://autobuild.buildroot.net/results/a4cf71c34dcc5c750ea87a16014c2cb2d28cdebd/
  (elfutils)

  http://autobuild.buildroot.net/results/cb9ae18295b21b3f9399be6edd82273add375656/
  (linux-pam)

  http://autobuild.buildroot.net/results/4225e5dfb6bcf590d9c1068112472ee82bc87d6b/
  (alsa-utils)

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gettext/Config.in
package/gettext/gettext.mk

index 0dea03d18d7a082c2f4d2fa2595a82e1a6068270..bf16c34d3e13f773ff2234fe77ed542b0628502a 100644 (file)
@@ -17,7 +17,7 @@ if BR2_PACKAGE_GETTEXT
 config BR2_PACKAGE_GETTEXT_PROVIDES_LIBINTL
        bool
        depends on !BR2_TOOLCHAIN_HAS_FULL_GETTEXT
-       default y if BR2_SYSTEM_ENABLE_NLS
+       default y
 
 endif
 
index 454ad298a936463cf7eabc2cecb7e29695767388..f3325dc6c138f93aed041496420433d3bab3ef74 100644 (file)
@@ -42,7 +42,7 @@ HOST_GETTEXT_CONF_OPTS = \
 # Force the build of libintl, even if the C library provides a stub
 # gettext implementation
 ifeq ($(BR2_PACKAGE_GETTEXT_PROVIDES_LIBINTL),y)
-GETTEXT_CONF_OPTS += --with-included-gettext
+GETTEXT_CONF_OPTS += --with-included-gettext --enable-nls
 else
 GETTEXT_CONF_OPTS += --without-included-gettext
 endif