projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
53796ad
)
package/qemu: enable NUMA support if numactl is selected
author
Carlos Santos
<unixmania@gmail.com>
Tue, 22 Oct 2019 22:47:39 +0000
(19:47 -0300)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Fri, 25 Oct 2019 18:19:35 +0000
(20:19 +0200)
This is helpful for the upcoming libvirt package.
Signed-off-by: Carlos Santos <unixmania@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qemu/qemu.mk
patch
|
blob
|
history
diff --git
a/package/qemu/qemu.mk
b/package/qemu/qemu.mk
index 5f97dab39f1867468028a27ea86cd67e0a95013f..3c8b0f43d8529445d06ea62774392acd161f0918 100644
(file)
--- a/
package/qemu/qemu.mk
+++ b/
package/qemu/qemu.mk
@@
-104,6
+104,13
@@
else
QEMU_OPTS += --disable-nettle
endif
+ifeq ($(BR2_PACKAGE_NUMACTL),y)
+QEMU_OPTS += --enable-numa
+QEMU_DEPENDENCIES += numactl
+else
+QEMU_OPTS += --disable-numa
+endif
+
# Override CPP, as it expects to be able to call it like it'd
# call the compiler.
define QEMU_CONFIGURE_CMDS