arch: remove support for sh64
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 8 Sep 2016 18:38:57 +0000 (15:38 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 8 Sep 2016 20:15:15 +0000 (22:15 +0200)
It's been deprecated for quite some time now.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
.defconfig
arch/Config.in
arch/Config.in.sh
linux/Config.in
package/fdk-aac/Config.in
package/gauche/Config.in
package/gdb/Config.in
package/libunwind/Config.in
package/ruby/ruby.mk
toolchain/toolchain-buildroot/Config.in

index 037647e2234c8caf91ac14de2ce919df99a35195..7ab0c3fbf061d3ac17ca94cd11ca3ae98de0458c 100644 (file)
@@ -15,7 +15,6 @@ BR2_i386=y
 # BR2_nios2 is not set
 # BR2_powerpc is not set
 # BR2_sh is not set
-# BR2_sh64 is not set
 # BR2_sparc is not set
 # BR2_sparc64 is not set
 # BR2_x86_64 is not set
index 3caca158eb258520a9729447db34b189cdaed45a..df4db0b796303e924970d13e861d0ceedf3941cb 100644 (file)
@@ -197,16 +197,6 @@ config BR2_sh
          http://www.hitachi.com/
          http://en.wikipedia.org/wiki/SuperH
 
-config BR2_sh64
-       bool "SuperH64"
-       depends on BR2_DEPRECATED_SINCE_2015_05
-       select BR2_ARCH_HAS_MMU_MANDATORY
-       help
-         SuperH64 (or SH) is a 64-bit reduced instruction set computer (RISC)
-         instruction set architecture (ISA) developed by Hitachi.
-         http://www.hitachi.com/
-         http://en.wikipedia.org/wiki/SuperH
-
 config BR2_sparc
        bool "SPARC"
        select BR2_ARCH_HAS_MMU_MANDATORY
@@ -396,7 +386,7 @@ if BR2_powerpc || BR2_powerpc64 || BR2_powerpc64le
 source "arch/Config.in.powerpc"
 endif
 
-if BR2_sh || BR2_sh64
+if BR2_sh
 source "arch/Config.in.sh"
 endif
 
index 1bdea37cbc550601bc7f088e5b1951eca8b1bd87..4705212583aa8af58e20cc806961d16cfb9fca3c 100644 (file)
@@ -23,8 +23,7 @@ config BR2_ARCH
        default "sh4eb"         if BR2_sh4eb
        default "sh4a"          if BR2_sh4a
        default "sh4aeb"        if BR2_sh4aeb
-       default "sh64"          if BR2_sh64
 
 config BR2_ENDIAN
-       default "LITTLE"        if BR2_sh4 || BR2_sh4a || BR2_sh64
+       default "LITTLE"        if BR2_sh4 || BR2_sh4a
        default "BIG"           if BR2_sh2a || BR2_sh4eb || BR2_sh4aeb
index 4b701a4a91edf25c7f28042e8386cc8720c94998..fd6b4b3d49695d7766a7139a063d0790b623d866 100644 (file)
@@ -179,7 +179,7 @@ config BR2_LINUX_KERNEL_UIMAGE
        bool "uImage"
        depends on BR2_arc || BR2_arm || BR2_armeb || BR2_bfin || \
                   BR2_powerpc || BR2_powerpc64 || BR2_powerpc64le || \
-                  BR2_sh || BR2_sh64 || BR2_mips || BR2_mipsel || \
+                  BR2_sh || BR2_mips || BR2_mipsel || \
                   BR2_mips64 || BR2_mips64el
        select BR2_LINUX_KERNEL_UBOOT_IMAGE
 
@@ -198,7 +198,7 @@ config BR2_LINUX_KERNEL_ZIMAGE
        bool "zImage"
        depends on BR2_arm || BR2_armeb || BR2_powerpc || \
                   BR2_powerpc64 || BR2_powerpc64le || BR2_sparc || \
-                  BR2_sh || BR2_sh64 || BR2_xtensa
+                  BR2_sh || BR2_xtensa
 
 config BR2_LINUX_KERNEL_ZIMAGE_EPAPR
        bool "zImage.epapr"
@@ -235,7 +235,7 @@ config BR2_LINUX_KERNEL_LINUX_BIN
 
 config BR2_LINUX_KERNEL_VMLINUX_BIN
        bool "vmlinux.bin"
-       depends on BR2_mips || BR2_mipsel || BR2_sh || BR2_sh64
+       depends on BR2_mips || BR2_mipsel || BR2_sh
 
 config BR2_LINUX_KERNEL_VMLINUX
        bool "vmlinux"
index 1ec59e1a889b5ae2ad751b0112c02b7fdc871240..9e18d22039c109daaa69dcebef1af3c607685285 100644 (file)
@@ -4,7 +4,7 @@ config BR2_PACKAGE_FDK_AAC
        # These are the architectures supported by FDK AAC
        depends on BR2_i386 || BR2_x86_64 || BR2_arm || BR2_armeb || \
                   BR2_mips || BR2_mipsel || BR2_mips64 || BR2_mips64el || \
-                  BR2_powerpc || BR2_sh || BR2_sh64
+                  BR2_powerpc || BR2_sh
 
        help
          The Fraunhofer FDK AAC Codec Library for Android ("FDK AAC Codec")
@@ -17,4 +17,4 @@ comment "fdk-aac needs a toolchain w/ C++"
        depends on !BR2_INSTALL_LIBSTDCPP
        depends on BR2_i386 || BR2_x86_64 || BR2_arm || BR2_armeb || \
                   BR2_mips || BR2_mipsel || BR2_mips64 || BR2_mips64el || \
-                  BR2_powerpc || BR2_sh || BR2_sh64
+                  BR2_powerpc || BR2_sh
index 3ca012d3f8bfec4b743df0969de3f916e80f8a6f..c5f2a51948bd433fb673233bc03d56ce35f3db86 100644 (file)
@@ -4,7 +4,7 @@ config BR2_PACKAGE_GAUCHE_ARCH_SUPPORTS
        default y if BR2_arm || BR2_armeb || BR2_i386 || BR2_m68k || \
                BR2_mips || BR2_mipsel || BR2_mips64 || \
                BR2_mips64el || BR2_powerpc || BR2_powerpc64 || \
-               BR2_powerpc64le || BR2_sh || BR2_sh64 || BR2_x86_64
+               BR2_powerpc64le || BR2_sh || BR2_x86_64
 
 config BR2_PACKAGE_GAUCHE
        bool "gauche"
index feab01da9e92742a422aab4af6d827c1f271d877..809e02d0763606d1556ebcb4a6c622a84ec69373 100644 (file)
@@ -40,10 +40,10 @@ config BR2_PACKAGE_GDB_DEBUGGER
        bool "full debugger"
        select BR2_PACKAGE_NCURSES
        depends on BR2_USE_WCHAR
-       depends on !BR2_sh && !BR2_sh64 && !BR2_microblaze
+       depends on !BR2_sh && !BR2_microblaze
 
 comment "full gdb on target needs a toolchain w/ wchar"
-       depends on !BR2_sh && !BR2_sh64 && !BR2_microblaze
+       depends on !BR2_sh && !BR2_microblaze
        depends on !BR2_USE_WCHAR
 
 if BR2_PACKAGE_GDB_DEBUGGER
index 04ab5a5c5cdd261a91e0ebbc4ad61b91c6a5c0aa..5527a2bc21a5278329a1852a82b7cc16b4af16a4 100644 (file)
@@ -12,7 +12,7 @@ config BR2_PACKAGE_LIBUNWIND_ARCH_SUPPORTS
        default y if BR2_TOOLCHAIN_USES_GLIBC && \
                (((BR2_arm || BR2_armeb) && BR2_ARM_CPU_HAS_ARM) || \
                 BR2_mips || BR2_mipsel || BR2_mips64 || \
-                BR2_mips64el || BR2_powerpc || BR2_sh || BR2_sh64 || BR2_i386 || BR2_x86_64)
+                BR2_mips64el || BR2_powerpc || BR2_sh || BR2_i386 || BR2_x86_64)
        default y if BR2_TOOLCHAIN_USES_UCLIBC && \
                (((BR2_arm || BR2_armeb) && BR2_ARM_CPU_HAS_ARM) || \
                 BR2_i386 || BR2_mips || BR2_mipsel || \
index 3b8310c112aac880cc604bb8526cfe4c4ef3ba65..f3f80475b8230a615b74ab15db6bf8b87d165261 100644 (file)
@@ -24,7 +24,7 @@ RUBY_CFLAGS = $(TARGET_CFLAGS)
 # With some SuperH toolchains (like Sourcery CodeBench 2012.09), ruby fails to
 # build with 'pcrel too far'. This seems to be caused by the -Os option we pass
 # by default. To fix the problem, use standard -O2 optimization instead.
-ifeq ($(BR2_sh)$(BR2_sh64),y)
+ifeq ($(BR2_sh),y)
 RUBY_CFLAGS += -O2
 endif
 RUBY_CONF_ENV = CFLAGS="$(RUBY_CFLAGS)"
index 9fdfb4282f9cf81e71627d3060bc608c4ff5d2ff..8e275c22f26bcab5a778dedf97057643e0885f3c 100644 (file)
@@ -48,8 +48,8 @@ config BR2_TOOLCHAIN_BUILDROOT_GLIBC
                   BR2_aarch64_be  || BR2_i386       || BR2_mips    || \
                   BR2_mipsel      || BR2_mips64     || BR2_mips64el|| \
                   BR2_powerpc     || BR2_powerpc64  || BR2_powerpc64le || \
-                  BR2_sh          || BR2_sh64       || BR2_sparc64 || \
-                  BR2_x86_64      || BR2_microblaze || BR2_nios2
+                  BR2_sh          || BR2_sparc64    || BR2_x86_64 || \
+                  BR2_microblaze || BR2_nios2
        depends on BR2_USE_MMU
        depends on !BR2_STATIC_LIBS
        depends on !BR2_powerpc_SPE