package/boost: don't install boost cmake files
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 18 Apr 2019 09:13:50 +0000 (11:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 18 Apr 2019 09:25:28 +0000 (11:25 +0200)
Since version 1.70.0, boost installs its own cmake files which are
utterly broken so don't install them otherwise all cmake packages using
boost (host-thrift, domoticz, i2pd ...) will fail because
BOOST_INCLUDE_DIRS will be empty

Fixes:
 - http://autobuild.buildroot.org/results/4ada26bab5c1e6504c7d8c92672326ced1d336df

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/boost/boost.mk

index 920a3dd37f7ddf74eee3b54e06def6d95e714ae8..a2d8395fd425a82e0f9134d791db86c1bda1e1cb 100644 (file)
@@ -76,8 +76,8 @@ BOOST_DEPENDENCIES += python
 endif
 endif
 
-HOST_BOOST_OPTS += toolset=gcc threading=multi variant=release link=shared \
-       runtime-link=shared
+HOST_BOOST_OPTS += --no-cmake-config toolset=gcc threading=multi \
+       variant=release link=shared runtime-link=shared
 
 ifeq ($(BR2_MIPS_OABI32),y)
 BOOST_ABI = o32
@@ -87,7 +87,8 @@ else
 BOOST_ABI = sysv
 endif
 
-BOOST_OPTS += toolset=gcc \
+BOOST_OPTS += --no-cmake-config \
+            toolset=gcc \
             threading=multi \
             abi=$(BOOST_ABI) \
             variant=$(if $(BR2_ENABLE_DEBUG),debug,release)