Prevent install from following symlinks and overwriting bin/busybox
authorEric Andersen <andersen@codepoet.org>
Wed, 3 Dec 2003 17:18:41 +0000 (17:18 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 3 Dec 2003 17:18:41 +0000 (17:18 -0000)
make/bzip2.mk

index 6aa4a88dfacc5e2df71964111586475050050b77..299105a911f63f4db11ce290005e8c18b69fe282 100644 (file)
@@ -42,6 +42,8 @@ $(BZIP2_BINARY): $(STAGING_DIR)/lib/libbz2.so.1.0.2
        $(MAKE) CC=$(TARGET_CC) -C $(BZIP2_DIR) bzip2 bzip2recover
 
 $(BZIP2_TARGET_BINARY): $(BZIP2_BINARY)
+       (cd $(TARGET_DIR)/usr/bin; \
+       rm -f bzip2 bunzip2 bzcat bzip2recover bzgrep bzegrep bzfgrep bzmore bzless bzdiff bzcmp);
        $(TARGET_CONFIGURE_OPTS) \
        $(MAKE) PREFIX=$(TARGET_DIR)/usr -C $(BZIP2_DIR) install
        rm -f $(TARGET_DIR)/usr/lib/libbz2.a