package/mg: new package
authorJoachim Wiberg <troglobit@gmail.com>
Tue, 1 Sep 2020 05:38:59 +0000 (07:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 4 Sep 2020 08:28:43 +0000 (10:28 +0200)
Mg is a small Emacs-like editor with no external dependencies except a
standard C library.  It weighs in at 130 kiB and is one of a select few
completely free (public domain) text editors suitable for small and
embedded systems.

This version is based on the OpenBSD Mg, but with more features, one of
which being the no-ncurses/termcap support, which heavily reduces the
impact on a resource constrained system.

Upstream: https://github.com/troglobit/mg/

Signed-off-by: Joachim Wiberg <troglobit@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/mg/Config.in [new file with mode: 0644]
package/mg/mg.hash [new file with mode: 0644]
package/mg/mg.mk [new file with mode: 0644]

index ee17e530115fdedbdf97a69a2c75b247b98d6657..d306c5f025c0e545cb93bcdffed714349f9865a9 100644 (file)
@@ -1300,9 +1300,10 @@ F:       package/libuhttpd/
 F:     package/libuwsc/
 F:     package/rtty/
 
-N:     Joachim Nilsson <troglobit@gmail.com>
+N:     Joachim Wiberg <troglobit@gmail.com>
 F:     configs/globalscale_espressobin_defconfig
 F:     board/globalscale/espressobin/
+F:     package/mg/
 
 N:     Joao Pinto <jpinto@synopsys.com>
 F:     board/synopsys/vdk/
index 87e7f4274a83c5f00c2a4926e732f91f1a5768dd..3b6ced8f0f19f0c11d74241b0b1bcccb1a48cc01 100644 (file)
@@ -2447,6 +2447,7 @@ menu "Text editors and viewers"
        source "package/joe/Config.in"
        source "package/less/Config.in"
        source "package/mc/Config.in"
+       source "package/mg/Config.in"
        source "package/most/Config.in"
        source "package/nano/Config.in"
        source "package/uemacs/Config.in"
diff --git a/package/mg/Config.in b/package/mg/Config.in
new file mode 100644 (file)
index 0000000..11e5bdb
--- /dev/null
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_MG
+       bool "mg"
+       depends on BR2_USE_MMU # fork()
+       help
+         Emacs-like text editor (130 kiB)
+
+         Mg is a MicroEMACS clone with the goal of being compatible
+         with GNU Emacs, because there should never be any reason to
+         learn more than one Emacs flavor.
+
+         Unlike many other editors it does not require ncurses, only a
+         standard C library, making it suitable for really small and
+         embedded systems.
+
+         This version is based on mg2a from OpenBSD, with more features
+         and, in particular, no requirement on ncurses or termcap.
+
+         https://github.com/troglobit/mg/
diff --git a/package/mg/mg.hash b/package/mg/mg.hash
new file mode 100644 (file)
index 0000000..758a523
--- /dev/null
@@ -0,0 +1,5 @@
+# From https://github.com/troglobit/mg/releases/tag/v3.4
+md5 6b79855d54770bcb23e5457ebde8296c  mg-3.4.tar.gz
+# Locally computed:
+sha256 1a620cf5b2dd4b00006d6c929ac8e2a70eeab5f807a0d6e5334b878aa182b713  mg-3.4.tar.gz
+sha256 7e12e5df4bae12cb21581ba157ced20e1986a0508dd10d0e8a4ab9a4cf94e85c  UNLICENSE
diff --git a/package/mg/mg.mk b/package/mg/mg.mk
new file mode 100644 (file)
index 0000000..e3b79da
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# mg
+#
+################################################################################
+
+MG_VERSION = 3.4
+MG_SITE = https://github.com/troglobit/mg/releases/download/v$(MG_VERSION)
+MG_LICENSE = Public Domain
+MG_LICENSE_FILES = UNLICENSE
+
+ifeq ($(BR2_PACKAGE_NCURSES),y)
+MG_DEPENDENCIES += ncurses
+MG_CONF_OPTS += --with-curses
+else
+MG_CONF_OPTS += --without-curses
+endif
+
+$(eval $(autotools-package))