package/bustle: bump to version 0.8.0
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 23 Dec 2020 11:33:54 +0000 (12:33 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Dec 2020 17:21:34 +0000 (18:21 +0100)
- Update license hash and remove GPL-3.0:
  https://gitlab.freedesktop.org/bustle/bustle/-/commit/c3f2f160c528c874c483a314ebbf997abfd85492
- Use PCAP_CONFIG which is available since
  https://gitlab.freedesktop.org/bustle/bustle/-/commit/7e2daf2984fc4d479b153e899b80e8d669ff54cf
- Update indentation in hash file (two spaces)

https://hackage.haskell.org/package/bustle-0.8.0/changelog

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/bustle/bustle.hash
package/bustle/bustle.mk

index 05281c4f110fc966a717ed6345c7d23e76baa66d..0bb899f1c4f9252dee0228aa8db9568ee14f8277 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 7760a695b25cb264e7342f353dcdc6d2b7faeacdcd85dd14e03c61b18e791664  bustle-0.7.5.tar.gz
-sha256 a6d6109e5b086de8e852e451b91b08b323302f55b6975d506c64c43bb094be38  LICENSE
+sha256  2fb3e9d9a97db3cd9a3ce763e86947b642bd7733b46206177a1677f08726573c  bustle-0.8.0.tar.gz
+sha256  ad168b537264fba8f94380cb10f60847da7db551fb4281bb6d4f24c74f652a1d  LICENSE
index 1dbad64aef064f23c6e0e6668bfaa637abcdd5df..c6c3a72a9110fae15ba49bc4eff2839e5390379b 100644 (file)
@@ -4,20 +4,16 @@
 #
 ################################################################################
 
-BUSTLE_VERSION = 0.7.5
-BUSTLE_SITE = https://www.freedesktop.org/software/bustle/$(BUSTLE_VERSION)
-BUSTLE_LICENSE = LGPL-2.1+, GPL-3.0 (binaries)
+BUSTLE_VERSION = 0.8.0
+BUSTLE_SITE = https://hackage.haskell.org/package/bustle-$(BUSTLE_VERSION)
+BUSTLE_LICENSE = LGPL-2.1+
 BUSTLE_LICENSE_FILES = LICENSE
 BUSTLE_DEPENDENCIES = libglib2 libpcap host-pkgconf
-
-BUSTLE_PCAP_FLAGS = "-lpcap"
-ifeq ($(BR2_STATIC_LIBS),y)
-BUSTLE_PCAP_FLAGS += `$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`
-endif
+BUSTLE_MAKE_OPTS = PCAP_CONFIG=$(STAGING_DIR)/usr/bin/pcap-config
 
 define BUSTLE_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
-               PCAP_FLAGS="$(BUSTLE_PCAP_FLAGS)" -C $(@D) dist/build/bustle-pcap
+               $(BUSTLE_MAKE_OPTS) -C $(@D) dist/build/bustle-pcap
 endef
 
 define BUSTLE_INSTALL_TARGET_CMDS