gptfdisk: ensure correct libintl/libiconv build order
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 25 May 2015 19:58:03 +0000 (21:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 25 May 2015 19:58:03 +0000 (21:58 +0200)
Fixes:
http://autobuild.buildroot.net/results/c7d/c7d48554d76e39cbdf715721ae51e3516a99f97e/

We're explicitly linking against libintl/libiconv if enabled when linking
statically, but weren't ensuring that those libraries had already been built
before gptfdisk leading to linker issues.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gptfdisk/gptfdisk.mk

index e84e3d39e8ff0933c0e9c22b1f4fd8e78d997fd9..f812376dead1a784aeeee21b70101f31b5898804 100644 (file)
@@ -24,9 +24,15 @@ endif
 ifeq ($(BR2_STATIC_LIBS),y)
 # gptfdisk dependencies may link against libintl/libiconv, so we need
 # to do so as well when linking statically
-GPTFDISK_LDLIBS = \
-       $(if $(BR2_PACKAGE_GETTEXT),-lintl) \
-       $(if $(BR2_PACKAGE_LIBICONV),-liconv)
+ifeq ($(BR2_PACKAGE_GETTEXT),y)
+GPTFDISK_DEPENDENCIES += gettext
+GPTFDISK_LDLIBS += -lintl
+endif
+
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+GPTFDISK_DEPENDENCIES += libiconv
+GPTFDISK_LDLIBS += -liconv
+endif
 endif
 
 define GPTFDISK_BUILD_CMDS