libgtk2: remove useless post-patch hook
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 May 2013 13:01:03 +0000 (13:01 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 30 May 2013 19:52:01 +0000 (21:52 +0200)
There used to be a post-patch hook to apply a patch only on the host
variant of libgtk2. However, after the reorganization of the patch
naming policy, this was no longer working properly, so
dd1848bc73ee9dfe211ca3ed3a233707e3bc5955 changed this by a patch that
works on both the target and host variants.

We can therefore get rid of the useless post-patch hook.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libgtk2/libgtk2.mk

index b1ce99ae1769689f635857f60dd3beb6337a5316..5881ea78abb4ba0d39f32a78e487010b98181543 100644 (file)
@@ -175,12 +175,6 @@ HOST_LIBGTK2_CONF_OPT = \
                --disable-cups \
                --disable-debug
 
-define HOST_LIBGTK2_PATCH_REDUCE_DEPENDENCIES_HOOK
- support/scripts/apply-patches.sh $(@D) $($(PKG)_DIR_PREFIX)/$(RAWNAME) host-*.patch
-endef
-
-HOST_LIBGTK2_POST_PATCH_HOOKS += HOST_LIBGTK2_PATCH_REDUCE_DEPENDENCIES_HOOK
-
 define HOST_LIBGTK2_BUILD_CMDS
  $(HOST_MAKE_ENV) make -C $(@D)/gtk gtk-update-icon-cache
 endef