package/libvips: add zlib optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 4 Apr 2021 14:30:42 +0000 (16:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 4 Apr 2021 14:44:32 +0000 (16:44 +0200)
zlib is an optional dependency which is enabled by default since version
8.4.2 and
https://github.com/libvips/libvips/commit/5ab0001ec68a5f61396aecd8d2d7a619b1dbe1fa

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libvips/libvips.mk

index 0449751380b74e20a2594125695a8a912ad2b6c4..5f95fc7f1dabc6e1ce1a1405ae044e0dedeebbfe 100644 (file)
@@ -94,4 +94,11 @@ else
 LIBVIPS_CONF_OPTS += --without-libexif
 endif
 
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+LIBVIPS_CONF_OPTS += --with-zlib
+LIBVIPS_DEPENDENCIES += zlib
+else
+LIBVIPS_CONF_OPTS += --without-zlib
+endif
+
 $(eval $(autotools-package))