package/openal: bump to version 1.20.1
authorAndré Hentschel <nerv@dawncrow.de>
Thu, 13 Aug 2020 18:24:45 +0000 (20:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 13 Aug 2020 20:40:10 +0000 (22:40 +0200)
This will fix the build with gcc 10 due to the library codebase being
switched to C++11.

It should be noted that bumping the C++ requirement from C++11 to C++14
is not needed for this bump as this change is not yet in this version:
https://github.com/kcat/openal-soft/commit/f6a0b004e0424e1f12a226b3b3c7193063eb02e3

Also update indentation in hash file (two spaces)

Fixes:
 - http://autobuild.buildroot.org/results/4546ce4f176164462b0e73c387bc45c9771f98f7

Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/openal/Config.in
package/openal/openal.hash
package/openal/openal.mk
package/supertuxkart/Config.in

index 08de5d2188cf5ca2325764922e51e0a5c4869a16..6190cb5028c0656c9e2eb08ae436fb6f7f1b1719 100644 (file)
@@ -489,14 +489,16 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_NEON
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPENAL
        bool "openal"
        depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
        depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
        depends on BR2_PAKCAGE_OPENAL_ARCH_SUPPORTS
        select BR2_PACKAGE_OPENAL
 
-comment "openal plugin needs a toolchain w/ NPTL, C++"
+comment "openal plugin needs a toolchain w/ NPTL, C++, gcc >= 4.7"
        depends on BR2_PAKCAGE_OPENAL_ARCH_SUPPORTS
        depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL \
-               || !BR2_INSTALL_LIBSTDCPP
+               || !BR2_INSTALL_LIBSTDCPP \
+               || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
 
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_OPENH264
        bool "openh264"
index a564156555fb81fab25b2465db8f241f8ee14b20..7025c131e81f8e36b9d9499c65756d62e9b4e017 100644 (file)
@@ -16,6 +16,7 @@ config BR2_PACKAGE_OPENAL_ARCH_SUPPORTS
 config BR2_PACKAGE_OPENAL
        bool "openal"
        depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 # C++11
        depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
        depends on BR2_PACKAGE_OPENAL_ARCH_SUPPORTS
        help
@@ -26,7 +27,8 @@ config BR2_PACKAGE_OPENAL
 
          http://kcat.strangesoft.net/openal.html
 
-comment "openal needs a toolchain w/ NPTL, C++"
+comment "openal needs a toolchain w/ NPTL, C++, gcc >= 4.7"
        depends on BR2_PACKAGE_OPENAL_ARCH_SUPPORTS
        depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL \
-               || !BR2_INSTALL_LIBSTDCPP
+               || !BR2_INSTALL_LIBSTDCPP \
+               || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
index a133808cae3526ffecda0f192fc5d088b45e1266..1592dd56b5f687f762df9811081fa68bb4d2d33a 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 9f3536ab2bb7781dbafabc6a61e0b34b17edd16bd6c2eaf2ae71bc63078f98c7  openal-1.19.1.tar.gz
-sha256 d808ce217e5b611854da622b57ec29fe545584c48bc5352fae72a4b6e5074a15  COPYING
+sha256  c32d10473457a8b545aab50070fe84be2b5b041e1f2099012777ee6be0057c13  openal-1.20.1.tar.gz
+sha256  d808ce217e5b611854da622b57ec29fe545584c48bc5352fae72a4b6e5074a15  COPYING
index 8e761a8d9bfb5b455c15024038ef25f3da91a3cb..ed63abfb3f04c71d664f31a8557980fee5495124 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-OPENAL_VERSION = 1.19.1
+OPENAL_VERSION = 1.20.1
 OPENAL_SITE = $(call github,kcat,openal-soft,openal-soft-$(OPENAL_VERSION))
 OPENAL_LICENSE = LGPL-2.0+
 OPENAL_LICENSE_FILES = COPYING
index e00d98d2a40bd3433f91dc797a04a8b46b2ee639..b8ac3ae2618c33987d229e601bc879405269e37c 100644 (file)
@@ -4,6 +4,7 @@ config BR2_PACKAGE_SUPERTUXKART
        depends on BR2_i386 || BR2_x86_64
        depends on BR2_USE_MMU # fork()
        depends on BR2_INSTALL_LIBSTDCPP # openal
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 # openal
        depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL # openal
        depends on BR2_PACKAGE_OPENAL_ARCH_SUPPORTS # openal
        depends on BR2_PACKAGE_HAS_LIBGL
@@ -32,7 +33,7 @@ config BR2_PACKAGE_SUPERTUXKART
 
          http://supertuxkart.sourceforge.net/Main_Page
 
-comment "supertuxkart needs an OpenGL backend, a uClibc or glibc toolchain w/ NPTL, C++"
+comment "supertuxkart needs an OpenGL backend, a uClibc or glibc toolchain w/ NPTL, C++, gcc >= 4.7"
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
        depends on BR2_i386 || BR2_x86_64
        depends on BR2_USE_MMU
@@ -40,5 +41,6 @@ comment "supertuxkart needs an OpenGL backend, a uClibc or glibc toolchain w/ NP
        depends on BR2_PACKAGE_XORG7
        depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL \
                || !BR2_INSTALL_LIBSTDCPP \
+               || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 \
                || !BR2_PACKAGE_HAS_LIBGL \
                || BR2_TOOLCHAIN_USES_MUSL