package/go-bootstrap: bump to version 1.4-bootstrap-20171003
authorChristian Stewart <christian@paral.in>
Tue, 22 Jun 2021 01:41:17 +0000 (18:41 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 21 Jul 2021 20:26:38 +0000 (22:26 +0200)
See https://golang.org/doc/install/source#bootstrapFromSource

All Go compiler versions > 1.4.x (old) are written in Go, and require a existing
compiled Go version to use to build from source. Buildroot uses a 1.4.x version
in the "go-bootstrap" package to build a C-based Go compiler, and then uses that
compiler to build the main "host-go" compiler.

This commit updates to the latest 1.4.x go-bootstrap branch version recommended
in the documentation, which includes more compatibility fixes.

Signed-off-by: Christian Stewart <christian@paral.in>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/go-bootstrap/go-bootstrap.hash
package/go-bootstrap/go-bootstrap.mk

index 03fd7d571f7e17e199eaebffc1bad931047cc754..0f186a5d55a21540bd8dc43f5778f0838c3097cd 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed:
-sha256  9947fc705b0b841b5938c48b22dc33e9647ec0752bae66e50278df4f23f64959  go1.4.3.src.tar.gz
+sha256  f4ff5b5eb3a3cae1c993723f3eab519c5bae18866b5e5f96fe1102f0cb5c3e52  go1.4-bootstrap-20171003.tar.gz
 sha256  dd26a7abddd02e2d0aba97805b31f248ef7835d9e10da289b22e3b8ab78b324d  LICENSE
index 6710e31561c9fdd84d89a01e27eed6ef7e8666ab..71696a1540e1090bb429b685a8463ca2b6a36cf6 100644 (file)
@@ -4,9 +4,11 @@
 #
 ################################################################################
 
-GO_BOOTSTRAP_VERSION = 1.4.3
-GO_BOOTSTRAP_SITE = https://storage.googleapis.com/golang
-GO_BOOTSTRAP_SOURCE = go$(GO_BOOTSTRAP_VERSION).src.tar.gz
+# Use last C-based Go compiler: v1.4.x
+# See https://golang.org/doc/install/source#bootstrapFromSource
+GO_BOOTSTRAP_VERSION = 1.4-bootstrap-20171003
+GO_BOOTSTRAP_SITE = https://dl.google.com/go
+GO_BOOTSTRAP_SOURCE = go$(GO_BOOTSTRAP_VERSION).tar.gz
 
 GO_BOOTSTRAP_LICENSE = BSD-3-Clause
 GO_BOOTSTRAP_LICENSE_FILES = LICENSE