buildroot: add QUIET variable and use it for wget/git/svn/configure
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 21 Oct 2008 08:56:26 +0000 (08:56 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 21 Oct 2008 08:56:26 +0000 (08:56 -0000)
A lot of tools take a -q option to be quiet.
Set this if make is called with the -s (silent) option and use for
wget, git, svn and configure.

package/Makefile.autotools.in
project/Makefile.in

index 9f7a54807ae5dda42e778a19a2ed543a4cf0907c..1a38d4ffbaf55bc4c0a7bf1990d434516eb45b72 100644 (file)
@@ -225,8 +225,7 @@ $(BUILD_DIR)/%/.stamp_configured:
                --prefix=/usr \
                --exec-prefix=/usr \
                --sysconfdir=/etc \
-               $(if $(findstring s,$(MAKEFLAGS)),--quiet,) \
-               $($(PKG)_CONF_OPT)
+               $(QUIET) $($(PKG)_CONF_OPT)
        $(Q)touch $@
 
 # Build
index cc1043ba199e53e4a2d2857f681b1ae0d9076ac4..fc73e407b6f4634302c91f70e9c6d6e961bff611 100644 (file)
@@ -5,17 +5,19 @@ TARGET_HOSTNAME:=$(strip $(subst ",,$(BR2_HOSTNAME)))
 BANNER:=$(strip $(subst ",,$(BR2_BANNER)))
 #"))
 
+# silent mode requested?
+QUIET:=$(if $(findstring s,$(MAKEFLAGS)),-q,)
 
 # Strip off the annoying quoting
 ARCH:=$(strip $(subst ",, $(BR2_ARCH)))
 #"))
-WGET:=$(strip $(subst ",, $(BR2_WGET))) $(SPIDER)
+WGET:=$(strip $(subst ",, $(BR2_WGET))) $(SPIDER) $(QUIET)
 #"))
-SVN_CO:=$(strip $(subst ",, $(BR2_SVN_CO)))
+SVN_CO:=$(strip $(subst ",, $(BR2_SVN_CO))) $(QUIET)
 #"))
-SVN_UP:=$(strip $(subst ",, $(BR2_SVN_UP)))
+SVN_UP:=$(strip $(subst ",, $(BR2_SVN_UP))) $(QUIET)
 #"))
-GIT:=$(strip $(subst ",, $(BR2_GIT)))
+GIT:=$(strip $(subst ",, $(BR2_GIT))) $(QUIET)
 #"))
 ZCAT:=$(strip $(subst ",, $(BR2_ZCAT)))
 #"))
@@ -24,7 +26,6 @@ BZCAT:=$(strip $(subst ",, $(BR2_BZCAT)))
 TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
 #")
 
-
 # Buildroot supports building out of tree similarly to the Linux kernel.
 # To use, add O= to the make command line (make O=/tmp/build)
 BASE_DIR:=$(shell pwd)