openssl: only build threads configuration if toolchain has pthread support
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 22 Nov 2013 21:38:58 +0000 (22:38 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 22 Nov 2013 21:44:54 +0000 (22:44 +0100)
Gets rid of a large number of warnings (and suboptimal code?):

..sysroot/usr/include/features.h:209:5: warning: #warning requested
reentrant code, but thread support was disabled [-Wcpp]

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/openssl/openssl.mk

index 4b8b0a4a1bdbafab85f437169e561cb293ba4621..5416141168ffe929a626cafddcea4318f75d8f1b 100644 (file)
@@ -73,7 +73,7 @@ define OPENSSL_CONFIGURE_CMDS
                        --prefix=/usr \
                        --openssldir=/etc/ssl \
                        --libdir=/lib \
-                       threads \
+                       $(if $(BR2_TOOLCHAIN_HAS_THREADS),threads,no-threads) \
                        $(if $(BR2_PREFER_STATIC_LIB),no-shared,shared) \
                        no-idea \
                        no-rc5 \