fix gcc 3.x/4.x symlinks to cc
authorIvan Kuten <ivan.kuten@promwad.com>
Thu, 13 Dec 2007 12:09:56 +0000 (12:09 -0000)
committerIvan Kuten <ivan.kuten@promwad.com>
Thu, 13 Dec 2007 12:09:56 +0000 (12:09 -0000)
toolchain/gcc/gcc-uclibc-3.x.mk
toolchain/gcc/gcc-uclibc-4.x.mk

index e2210d06c5dc977ad9c7b14f1c23713700e4108e..341be69573d5b6cf2d28ac3bd6ee979877297491 100644 (file)
@@ -293,8 +293,8 @@ endif
                ln -snf $(REAL_GNU_TARGET_NAME)-gcc \
                        $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc; \
        fi
-       if [ ! -e $(STAGING_DIR)/usr/bin/gcc ]; then \
-               ln -snf gcc $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc; \
+       if [ ! -e $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/cc ]; then \
+               ln -snf gcc $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/cc; \
        fi
        # Set up the symlinks to enable lying about target name.
        set -e; \
index cbf5095558e5e458c810344c5310fbdc4c70703c..9c2846beabc2489a8b021eafd1ce162183d2295a 100644 (file)
@@ -306,8 +306,8 @@ endif
                ln -snf $(REAL_GNU_TARGET_NAME)-gcc \
                        $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc; \
        fi
-       if [ ! -e $(STAGING_DIR)/usr/bin/cc ]; then \
-               ln -snf gcc $(STAGING_DIR)/usr/bin/cc; \
+       if [ ! -e $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/cc ]; then \
+               ln -snf gcc $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/cc; \
        fi
        # Set up the symlinks to enable lying about target name.
        set -e; \