zeromq: bump to version 4.1.2
authorJonathan Ben Avraham <yba@tkos.co.il>
Mon, 3 Aug 2015 15:51:12 +0000 (18:51 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Aug 2015 09:19:25 +0000 (11:19 +0200)
In the upstream git://github.com/zeromq/libzmq.git:

commit 6fdafc458a776e063511bb83dc7791aabea00b05 obviated the need for
0001-tests-disable-test_fork-if-fork-is-not-available.patch .

commit c8ee16940fff19ae3c12b4596c4bd131b2c71996 obviated the need for
0004-allow-without-libsodium.patch .

Fixed AUTORECONF comment in zeromq.mk to refer to the correct patch,
0001-acinclude.m4-make-kernel-specific-flags-cacheable.patch

Signed-off-by: Jonathan Ben Avraham <yba@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/zeromq/0001-acinclude.m4-make-kernel-specific-flags-cacheable.patch [new file with mode: 0644]
package/zeromq/0001-tests-disable-test_fork-if-fork-is-not-available.patch [deleted file]
package/zeromq/0002-acinclude.m4-make-kernel-specific-flags-cacheable.patch [deleted file]
package/zeromq/0002-libzmq-Fix-pkg-config-files-for-static-linking.patch [new file with mode: 0644]
package/zeromq/0003-libzmq-Fix-pkg-config-files-for-static-linking.patch [deleted file]
package/zeromq/0004-allow-without-libsodium.patch [deleted file]
package/zeromq/zeromq.hash
package/zeromq/zeromq.mk

diff --git a/package/zeromq/0001-acinclude.m4-make-kernel-specific-flags-cacheable.patch b/package/zeromq/0001-acinclude.m4-make-kernel-specific-flags-cacheable.patch
new file mode 100644 (file)
index 0000000..ff225d3
--- /dev/null
@@ -0,0 +1,199 @@
+commit 9daf6dd7c4947ce74ca729de5c3cfe8cbc304702
+Author: Lionel Orry <lionel.orry@gmail.com>
+Date:   Fri Feb 6 15:11:07 2015 +0100
+
+    acinclude.m4: make kernel-specific flags cacheable
+    
+    Specifically when cross-compiling, one can be willing to force these
+    variable values using the environment of a config.cache file. This
+    commit makes this possible.
+    
+    The affected variables are:
+    
+    * libzmq_cv_sock_cloexec
+    * libzmq_cv_so_keepalive
+    * libzmq_cv_tcp_keepcnt
+    * libzmq_cv_tcp_keepidle
+    * libzmq_cv_tcp_keepintvl
+    * libzmq_cv_tcp_keepalive
+    
+    Signed-off-by: Lionel Orry <lionel.orry@gmail.com>
+
+diff --git a/acinclude.m4 b/acinclude.m4
+index 4bbd19e..456740d 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -586,8 +586,8 @@ dnl # LIBZMQ_CHECK_SOCK_CLOEXEC([action-if-found], [action-if-not-found])
+ dnl # Check if SOCK_CLOEXEC is supported                                           #
+ dnl ################################################################################
+ AC_DEFUN([LIBZMQ_CHECK_SOCK_CLOEXEC], [{
+-    AC_MSG_CHECKING(whether SOCK_CLOEXEC is supported)
+-    AC_TRY_RUN([/* SOCK_CLOEXEC test */
++    AC_CACHE_CHECK([whether SOCK_CLOEXEC is supported], [libzmq_cv_sock_cloexec],
++        [AC_TRY_RUN([/* SOCK_CLOEXEC test */
+ #include <sys/types.h>
+ #include <sys/socket.h>
+@@ -596,11 +596,13 @@ int main (int argc, char *argv [])
+     int s = socket (PF_INET, SOCK_STREAM | SOCK_CLOEXEC, 0);
+     return (s == -1);
+ }
+-    ],
+-    [AC_MSG_RESULT(yes) ; libzmq_cv_sock_cloexec="yes" ; $1],
+-    [AC_MSG_RESULT(no)  ; libzmq_cv_sock_cloexec="no"  ; $2],
+-    [AC_MSG_RESULT(not during cross-compile) ; libzmq_cv_sock_cloexec="no"]
++        ],
++        [libzmq_cv_sock_cloexec="yes"],
++        [libzmq_cv_sock_cloexec="no"],
++        [libzmq_cv_sock_cloexec="not during cross-compile"]
++        )]
+     )
++    AS_IF([test "x$libzmq_cv_sock_cloexec" = "xyes"], [$1], [$2])
+ }])
+ dnl ################################################################################
+@@ -628,8 +630,8 @@ dnl # LIBZMQ_CHECK_SO_KEEPALIVE([action-if-found], [action-if-not-found])
+ dnl # Check if SO_KEEPALIVE is supported                                           #
+ dnl ################################################################################
+ AC_DEFUN([LIBZMQ_CHECK_SO_KEEPALIVE], [{
+-    AC_MSG_CHECKING(whether SO_KEEPALIVE is supported)
+-    AC_TRY_RUN([/* SO_KEEPALIVE test */
++    AC_CACHE_CHECK([whether SO_KEEPALIVE is supported], [libzmq_cv_so_keepalive],
++        [AC_TRY_RUN([/* SO_KEEPALIVE test */
+ #include <sys/types.h>
+ #include <sys/socket.h>
+@@ -641,11 +643,13 @@ int main (int argc, char *argv [])
+         ((rc = setsockopt (s, SOL_SOCKET, SO_KEEPALIVE, (char*) &opt, sizeof (int))) == -1)
+     );
+ }
+-    ],
+-    [AC_MSG_RESULT(yes) ; libzmq_cv_so_keepalive="yes" ; $1],
+-    [AC_MSG_RESULT(no)  ; libzmq_cv_so_keepalive="no"  ; $2],
+-    [AC_MSG_RESULT(not during cross-compile) ; libzmq_cv_so_keepalive="no"]
++        ],
++        [libzmq_cv_so_keepalive="yes"],
++        [libzmq_cv_so_keepalive="no"],
++        [libzmq_cv_so_keepalive="not during cross-compile"]
++        )]
+     )
++    AS_IF([test "x$libzmq_cv_so_keepalive" = "xyes"], [$1], [$2])
+ }])
+ dnl ################################################################################
+@@ -653,8 +657,8 @@ dnl # LIBZMQ_CHECK_TCP_KEEPCNT([action-if-found], [action-if-not-found])
+ dnl # Check if TCP_KEEPCNT is supported                                            #
+ dnl ################################################################################
+ AC_DEFUN([LIBZMQ_CHECK_TCP_KEEPCNT], [{
+-    AC_MSG_CHECKING(whether TCP_KEEPCNT is supported)
+-    AC_TRY_RUN([/* TCP_KEEPCNT test */
++    AC_CACHE_CHECK([whether TCP_KEEPCNT is supported], [libzmq_cv_tcp_keepcnt],
++        [AC_TRY_RUN([/* TCP_KEEPCNT test */
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+@@ -669,11 +673,13 @@ int main (int argc, char *argv [])
+         ((rc = setsockopt (s, IPPROTO_TCP, TCP_KEEPCNT, (char*) &opt, sizeof (int))) == -1)
+     );
+ }
+-    ],
+-    [AC_MSG_RESULT(yes) ; libzmq_cv_tcp_keepcnt="yes" ; $1],
+-    [AC_MSG_RESULT(no)  ; libzmq_cv_tcp_keepcnt="no"  ; $2],
+-    [AC_MSG_RESULT(not during cross-compile) ; libzmq_cv_tcp_keepcnt="no"]
++        ],
++        [libzmq_cv_tcp_keepcnt="yes"],
++        [libzmq_cv_tcp_keepcnt="no"],
++        [libzmq_cv_tcp_keepcnt="not during cross-compile"]
++        )]
+     )
++    AS_IF([test "x$libzmq_cv_tcp_keepcnt" = "xyes"], [$1], [$2])
+ }])
+ dnl ################################################################################
+@@ -681,8 +687,8 @@ dnl # LIBZMQ_CHECK_TCP_KEEPIDLE([action-if-found], [action-if-not-found])
+ dnl # Check if TCP_KEEPIDLE is supported                                           #
+ dnl ################################################################################
+ AC_DEFUN([LIBZMQ_CHECK_TCP_KEEPIDLE], [{
+-    AC_MSG_CHECKING(whether TCP_KEEPIDLE is supported)
+-    AC_TRY_RUN([/* TCP_KEEPIDLE test */
++    AC_CACHE_CHECK([whether TCP_KEEPIDLE is supported], [libzmq_cv_tcp_keepidle],
++        [AC_TRY_RUN([/* TCP_KEEPIDLE test */
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+@@ -697,11 +703,13 @@ int main (int argc, char *argv [])
+         ((rc = setsockopt (s, IPPROTO_TCP, TCP_KEEPIDLE, (char*) &opt, sizeof (int))) == -1)
+     );
+ }
+-    ],
+-    [AC_MSG_RESULT(yes) ; libzmq_cv_tcp_keepidle="yes" ; $1],
+-    [AC_MSG_RESULT(no)  ; libzmq_cv_tcp_keepidle="no"  ; $2],
+-    [AC_MSG_RESULT(not during cross-compile) ; libzmq_cv_tcp_keepidle="no"]
++        ],
++        [libzmq_cv_tcp_keepidle="yes"],
++        [libzmq_cv_tcp_keepidle="no"],
++        [libzmq_cv_tcp_keepidle="not during cross-compile"]
++        )]
+     )
++    AS_IF([test "x$libzmq_cv_tcp_keepidle" = "xyes"], [$1], [$2])
+ }])
+ dnl ################################################################################
+@@ -709,8 +717,8 @@ dnl # LIBZMQ_CHECK_TCP_KEEPINTVL([action-if-found], [action-if-not-found])
+ dnl # Check if TCP_KEEPINTVL is supported                                           #
+ dnl ################################################################################
+ AC_DEFUN([LIBZMQ_CHECK_TCP_KEEPINTVL], [{
+-    AC_MSG_CHECKING(whether TCP_KEEPINTVL is supported)
+-    AC_TRY_RUN([/* TCP_KEEPINTVL test */
++    AC_CACHE_CHECK([whether TCP_KEEPINTVL is supported], [libzmq_cv_tcp_keepintvl],
++        [AC_TRY_RUN([/* TCP_KEEPINTVL test */
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+@@ -725,11 +733,13 @@ int main (int argc, char *argv [])
+         ((rc = setsockopt (s, IPPROTO_TCP, TCP_KEEPINTVL, (char*) &opt, sizeof (int))) == -1)
+     );
+ }
+-    ],
+-    [AC_MSG_RESULT(yes) ; libzmq_cv_tcp_keepintvl="yes" ; $1],
+-    [AC_MSG_RESULT(no)  ; libzmq_cv_tcp_keepintvl="no"  ; $2],
+-    [AC_MSG_RESULT(not during cross-compile) ; libzmq_cv_tcp_keepintvl="no"]
++        ],
++        [libzmq_cv_tcp_keepintvl="yes"],
++        [libzmq_cv_tcp_keepintvl="no"],
++        [libzmq_cv_tcp_keepintvl="not during cross-compile"]
++        )]
+     )
++    AS_IF([test "x$libzmq_cv_tcp_keepintvl" = "xyes"], [$1], [$2])
+ }])
+ dnl ################################################################################
+@@ -737,8 +747,8 @@ dnl # LIBZMQ_CHECK_TCP_KEEPALIVE([action-if-found], [action-if-not-found])
+ dnl # Check if TCP_KEEPALIVE is supported                                          #
+ dnl ################################################################################
+ AC_DEFUN([LIBZMQ_CHECK_TCP_KEEPALIVE], [{
+-    AC_MSG_CHECKING(whether TCP_KEEPALIVE is supported)
+-    AC_TRY_RUN([/* TCP_KEEPALIVE test */
++    AC_CACHE_CHECK([whether TCP_KEEPALIVE is supported], [libzmq_cv_tcp_keepalive],
++        [AC_TRY_RUN([/* TCP_KEEPALIVE test */
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+@@ -753,11 +763,13 @@ int main (int argc, char *argv [])
+         ((rc = setsockopt (s, IPPROTO_TCP, TCP_KEEPALIVE, (char*) &opt, sizeof (int))) == -1)
+     );
+ }
+-    ],
+-    [AC_MSG_RESULT(yes) ; libzmq_cv_tcp_keepalive="yes" ; $1],
+-    [AC_MSG_RESULT(no)  ; libzmq_cv_tcp_keepalive="no"  ; $2],
+-    [AC_MSG_RESULT(not during cross-compile) ; libzmq_cv_tcp_keepalive="no"]
++        ],
++        [libzmq_cv_tcp_keepalive="yes"],
++        [libzmq_cv_tcp_keepalive="no"],
++        [libzmq_cv_tcp_keepalive="not during cross-compile"]
++        )]
+     )
++    AS_IF([test "x$libzmq_cv_tcp_keepalive" = "xyes"], [$1], [$2])
+ }])
+ dnl ################################################################################
diff --git a/package/zeromq/0001-tests-disable-test_fork-if-fork-is-not-available.patch b/package/zeromq/0001-tests-disable-test_fork-if-fork-is-not-available.patch
deleted file mode 100644 (file)
index 1eefdc3..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-From b50912f2eecec1ea7accc155f8132116f8702075 Mon Sep 17 00:00:00 2001
-From: Samuel Martin <s.martin49@gmail.com>
-Date: Sat, 3 May 2014 12:22:38 +0200
-Subject: [PATCH] tests: disable test_fork if fork() is not available
-
-Signed-off-by: Samuel Martin <s.martin49@gmail.com>
----
- configure.ac      | 1 +
- tests/Makefile.am | 8 ++++++--
- tests/Makefile.in | 8 ++++----
- 3 files changed, 11 insertions(+), 6 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 0c41604..8f8521c 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -431,6 +431,7 @@ AM_CONDITIONAL(BUILD_PGM, test "x$libzmq_pgm_ext" = "xyes")
- AM_CONDITIONAL(ON_MINGW, test "x$libzmq_on_mingw32" = "xyes")
- AM_CONDITIONAL(ON_ANDROID, test "x$libzmq_on_android" = "xyes")
- AM_CONDITIONAL(ON_LINUX, test "x$libzmq_on_linux" = "xyes")
-+AM_CONDITIONAL(HAVE_FORK, test "x$ac_cv_func_fork" = "xyes")
- # Checks for library functions.
- AC_TYPE_SIGNAL
-diff --git a/tests/Makefile.am b/tests/Makefile.am
-index 0cfe4e8..2a1e257 100644
---- a/tests/Makefile.am
-+++ b/tests/Makefile.am
-@@ -46,8 +46,10 @@ if !ON_MINGW
- noinst_PROGRAMS += test_shutdown_stress \
-                    test_pair_ipc \
-                    test_reqrep_ipc \
--                   test_timeo \
--                   test_fork
-+                   test_timeo
-+if HAVE_FORK
-+noinst_PROGRAMS += test_fork
-+endif
- endif
- test_system_SOURCES = test_system.cpp
-@@ -93,8 +95,10 @@ test_shutdown_stress_SOURCES = test_shutdown_stress.cpp
- test_pair_ipc_SOURCES = test_pair_ipc.cpp testutil.hpp
- test_reqrep_ipc_SOURCES = test_reqrep_ipc.cpp testutil.hpp
- test_timeo_SOURCES = test_timeo.cpp
-+if HAVE_FORK
- test_fork_SOURCES = test_fork.cpp
- endif
-+endif
- #  Run the test cases
- TESTS = $(noinst_PROGRAMS)
diff --git a/package/zeromq/0002-acinclude.m4-make-kernel-specific-flags-cacheable.patch b/package/zeromq/0002-acinclude.m4-make-kernel-specific-flags-cacheable.patch
deleted file mode 100644 (file)
index ff225d3..0000000
+++ /dev/null
@@ -1,199 +0,0 @@
-commit 9daf6dd7c4947ce74ca729de5c3cfe8cbc304702
-Author: Lionel Orry <lionel.orry@gmail.com>
-Date:   Fri Feb 6 15:11:07 2015 +0100
-
-    acinclude.m4: make kernel-specific flags cacheable
-    
-    Specifically when cross-compiling, one can be willing to force these
-    variable values using the environment of a config.cache file. This
-    commit makes this possible.
-    
-    The affected variables are:
-    
-    * libzmq_cv_sock_cloexec
-    * libzmq_cv_so_keepalive
-    * libzmq_cv_tcp_keepcnt
-    * libzmq_cv_tcp_keepidle
-    * libzmq_cv_tcp_keepintvl
-    * libzmq_cv_tcp_keepalive
-    
-    Signed-off-by: Lionel Orry <lionel.orry@gmail.com>
-
-diff --git a/acinclude.m4 b/acinclude.m4
-index 4bbd19e..456740d 100644
---- a/acinclude.m4
-+++ b/acinclude.m4
-@@ -586,8 +586,8 @@ dnl # LIBZMQ_CHECK_SOCK_CLOEXEC([action-if-found], [action-if-not-found])
- dnl # Check if SOCK_CLOEXEC is supported                                           #
- dnl ################################################################################
- AC_DEFUN([LIBZMQ_CHECK_SOCK_CLOEXEC], [{
--    AC_MSG_CHECKING(whether SOCK_CLOEXEC is supported)
--    AC_TRY_RUN([/* SOCK_CLOEXEC test */
-+    AC_CACHE_CHECK([whether SOCK_CLOEXEC is supported], [libzmq_cv_sock_cloexec],
-+        [AC_TRY_RUN([/* SOCK_CLOEXEC test */
- #include <sys/types.h>
- #include <sys/socket.h>
-@@ -596,11 +596,13 @@ int main (int argc, char *argv [])
-     int s = socket (PF_INET, SOCK_STREAM | SOCK_CLOEXEC, 0);
-     return (s == -1);
- }
--    ],
--    [AC_MSG_RESULT(yes) ; libzmq_cv_sock_cloexec="yes" ; $1],
--    [AC_MSG_RESULT(no)  ; libzmq_cv_sock_cloexec="no"  ; $2],
--    [AC_MSG_RESULT(not during cross-compile) ; libzmq_cv_sock_cloexec="no"]
-+        ],
-+        [libzmq_cv_sock_cloexec="yes"],
-+        [libzmq_cv_sock_cloexec="no"],
-+        [libzmq_cv_sock_cloexec="not during cross-compile"]
-+        )]
-     )
-+    AS_IF([test "x$libzmq_cv_sock_cloexec" = "xyes"], [$1], [$2])
- }])
- dnl ################################################################################
-@@ -628,8 +630,8 @@ dnl # LIBZMQ_CHECK_SO_KEEPALIVE([action-if-found], [action-if-not-found])
- dnl # Check if SO_KEEPALIVE is supported                                           #
- dnl ################################################################################
- AC_DEFUN([LIBZMQ_CHECK_SO_KEEPALIVE], [{
--    AC_MSG_CHECKING(whether SO_KEEPALIVE is supported)
--    AC_TRY_RUN([/* SO_KEEPALIVE test */
-+    AC_CACHE_CHECK([whether SO_KEEPALIVE is supported], [libzmq_cv_so_keepalive],
-+        [AC_TRY_RUN([/* SO_KEEPALIVE test */
- #include <sys/types.h>
- #include <sys/socket.h>
-@@ -641,11 +643,13 @@ int main (int argc, char *argv [])
-         ((rc = setsockopt (s, SOL_SOCKET, SO_KEEPALIVE, (char*) &opt, sizeof (int))) == -1)
-     );
- }
--    ],
--    [AC_MSG_RESULT(yes) ; libzmq_cv_so_keepalive="yes" ; $1],
--    [AC_MSG_RESULT(no)  ; libzmq_cv_so_keepalive="no"  ; $2],
--    [AC_MSG_RESULT(not during cross-compile) ; libzmq_cv_so_keepalive="no"]
-+        ],
-+        [libzmq_cv_so_keepalive="yes"],
-+        [libzmq_cv_so_keepalive="no"],
-+        [libzmq_cv_so_keepalive="not during cross-compile"]
-+        )]
-     )
-+    AS_IF([test "x$libzmq_cv_so_keepalive" = "xyes"], [$1], [$2])
- }])
- dnl ################################################################################
-@@ -653,8 +657,8 @@ dnl # LIBZMQ_CHECK_TCP_KEEPCNT([action-if-found], [action-if-not-found])
- dnl # Check if TCP_KEEPCNT is supported                                            #
- dnl ################################################################################
- AC_DEFUN([LIBZMQ_CHECK_TCP_KEEPCNT], [{
--    AC_MSG_CHECKING(whether TCP_KEEPCNT is supported)
--    AC_TRY_RUN([/* TCP_KEEPCNT test */
-+    AC_CACHE_CHECK([whether TCP_KEEPCNT is supported], [libzmq_cv_tcp_keepcnt],
-+        [AC_TRY_RUN([/* TCP_KEEPCNT test */
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
-@@ -669,11 +673,13 @@ int main (int argc, char *argv [])
-         ((rc = setsockopt (s, IPPROTO_TCP, TCP_KEEPCNT, (char*) &opt, sizeof (int))) == -1)
-     );
- }
--    ],
--    [AC_MSG_RESULT(yes) ; libzmq_cv_tcp_keepcnt="yes" ; $1],
--    [AC_MSG_RESULT(no)  ; libzmq_cv_tcp_keepcnt="no"  ; $2],
--    [AC_MSG_RESULT(not during cross-compile) ; libzmq_cv_tcp_keepcnt="no"]
-+        ],
-+        [libzmq_cv_tcp_keepcnt="yes"],
-+        [libzmq_cv_tcp_keepcnt="no"],
-+        [libzmq_cv_tcp_keepcnt="not during cross-compile"]
-+        )]
-     )
-+    AS_IF([test "x$libzmq_cv_tcp_keepcnt" = "xyes"], [$1], [$2])
- }])
- dnl ################################################################################
-@@ -681,8 +687,8 @@ dnl # LIBZMQ_CHECK_TCP_KEEPIDLE([action-if-found], [action-if-not-found])
- dnl # Check if TCP_KEEPIDLE is supported                                           #
- dnl ################################################################################
- AC_DEFUN([LIBZMQ_CHECK_TCP_KEEPIDLE], [{
--    AC_MSG_CHECKING(whether TCP_KEEPIDLE is supported)
--    AC_TRY_RUN([/* TCP_KEEPIDLE test */
-+    AC_CACHE_CHECK([whether TCP_KEEPIDLE is supported], [libzmq_cv_tcp_keepidle],
-+        [AC_TRY_RUN([/* TCP_KEEPIDLE test */
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
-@@ -697,11 +703,13 @@ int main (int argc, char *argv [])
-         ((rc = setsockopt (s, IPPROTO_TCP, TCP_KEEPIDLE, (char*) &opt, sizeof (int))) == -1)
-     );
- }
--    ],
--    [AC_MSG_RESULT(yes) ; libzmq_cv_tcp_keepidle="yes" ; $1],
--    [AC_MSG_RESULT(no)  ; libzmq_cv_tcp_keepidle="no"  ; $2],
--    [AC_MSG_RESULT(not during cross-compile) ; libzmq_cv_tcp_keepidle="no"]
-+        ],
-+        [libzmq_cv_tcp_keepidle="yes"],
-+        [libzmq_cv_tcp_keepidle="no"],
-+        [libzmq_cv_tcp_keepidle="not during cross-compile"]
-+        )]
-     )
-+    AS_IF([test "x$libzmq_cv_tcp_keepidle" = "xyes"], [$1], [$2])
- }])
- dnl ################################################################################
-@@ -709,8 +717,8 @@ dnl # LIBZMQ_CHECK_TCP_KEEPINTVL([action-if-found], [action-if-not-found])
- dnl # Check if TCP_KEEPINTVL is supported                                           #
- dnl ################################################################################
- AC_DEFUN([LIBZMQ_CHECK_TCP_KEEPINTVL], [{
--    AC_MSG_CHECKING(whether TCP_KEEPINTVL is supported)
--    AC_TRY_RUN([/* TCP_KEEPINTVL test */
-+    AC_CACHE_CHECK([whether TCP_KEEPINTVL is supported], [libzmq_cv_tcp_keepintvl],
-+        [AC_TRY_RUN([/* TCP_KEEPINTVL test */
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
-@@ -725,11 +733,13 @@ int main (int argc, char *argv [])
-         ((rc = setsockopt (s, IPPROTO_TCP, TCP_KEEPINTVL, (char*) &opt, sizeof (int))) == -1)
-     );
- }
--    ],
--    [AC_MSG_RESULT(yes) ; libzmq_cv_tcp_keepintvl="yes" ; $1],
--    [AC_MSG_RESULT(no)  ; libzmq_cv_tcp_keepintvl="no"  ; $2],
--    [AC_MSG_RESULT(not during cross-compile) ; libzmq_cv_tcp_keepintvl="no"]
-+        ],
-+        [libzmq_cv_tcp_keepintvl="yes"],
-+        [libzmq_cv_tcp_keepintvl="no"],
-+        [libzmq_cv_tcp_keepintvl="not during cross-compile"]
-+        )]
-     )
-+    AS_IF([test "x$libzmq_cv_tcp_keepintvl" = "xyes"], [$1], [$2])
- }])
- dnl ################################################################################
-@@ -737,8 +747,8 @@ dnl # LIBZMQ_CHECK_TCP_KEEPALIVE([action-if-found], [action-if-not-found])
- dnl # Check if TCP_KEEPALIVE is supported                                          #
- dnl ################################################################################
- AC_DEFUN([LIBZMQ_CHECK_TCP_KEEPALIVE], [{
--    AC_MSG_CHECKING(whether TCP_KEEPALIVE is supported)
--    AC_TRY_RUN([/* TCP_KEEPALIVE test */
-+    AC_CACHE_CHECK([whether TCP_KEEPALIVE is supported], [libzmq_cv_tcp_keepalive],
-+        [AC_TRY_RUN([/* TCP_KEEPALIVE test */
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
-@@ -753,11 +763,13 @@ int main (int argc, char *argv [])
-         ((rc = setsockopt (s, IPPROTO_TCP, TCP_KEEPALIVE, (char*) &opt, sizeof (int))) == -1)
-     );
- }
--    ],
--    [AC_MSG_RESULT(yes) ; libzmq_cv_tcp_keepalive="yes" ; $1],
--    [AC_MSG_RESULT(no)  ; libzmq_cv_tcp_keepalive="no"  ; $2],
--    [AC_MSG_RESULT(not during cross-compile) ; libzmq_cv_tcp_keepalive="no"]
-+        ],
-+        [libzmq_cv_tcp_keepalive="yes"],
-+        [libzmq_cv_tcp_keepalive="no"],
-+        [libzmq_cv_tcp_keepalive="not during cross-compile"]
-+        )]
-     )
-+    AS_IF([test "x$libzmq_cv_tcp_keepalive" = "xyes"], [$1], [$2])
- }])
- dnl ################################################################################
diff --git a/package/zeromq/0002-libzmq-Fix-pkg-config-files-for-static-linking.patch b/package/zeromq/0002-libzmq-Fix-pkg-config-files-for-static-linking.patch
new file mode 100644 (file)
index 0000000..11acec2
--- /dev/null
@@ -0,0 +1,29 @@
+From e89577d30c278fba0f9e40266ceb6fb2821907d5 Mon Sep 17 00:00:00 2001
+From: Peter Korsgaard <peter@korsgaard.com>
+Date: Wed, 13 May 2015 08:01:34 +0200
+Subject: [PATCH] libzmq: Fix pkg-config files for static linking
+
+Libzmq uses C++ standard library features, so users of it should link
+against that as well when statically linking.
+
+Add it to Libs.private so users using pkg-config automatically gets the
+correct linker flags.
+
+Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
+---
+ src/libzmq.pc.in       | 1 +
+ 1 file changed, 1 insertions(+)
+
+diff --git a/src/libzmq.pc.in b/src/libzmq.pc.in
+index ba155a3..52a39f7 100644
+--- a/src/libzmq.pc.in
++++ b/src/libzmq.pc.in
+@@ -7,4 +7,5 @@ Name: libzmq
+ Description: 0MQ c++ library
+ Version: @VERSION@
+ Libs: -L${libdir} -lzmq
++Libs.private: -lstdc++
+ Cflags: -I${includedir}
+-- 
+2.1.4
+
diff --git a/package/zeromq/0003-libzmq-Fix-pkg-config-files-for-static-linking.patch b/package/zeromq/0003-libzmq-Fix-pkg-config-files-for-static-linking.patch
deleted file mode 100644 (file)
index 11acec2..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From e89577d30c278fba0f9e40266ceb6fb2821907d5 Mon Sep 17 00:00:00 2001
-From: Peter Korsgaard <peter@korsgaard.com>
-Date: Wed, 13 May 2015 08:01:34 +0200
-Subject: [PATCH] libzmq: Fix pkg-config files for static linking
-
-Libzmq uses C++ standard library features, so users of it should link
-against that as well when statically linking.
-
-Add it to Libs.private so users using pkg-config automatically gets the
-correct linker flags.
-
-Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
----
- src/libzmq.pc.in       | 1 +
- 1 file changed, 1 insertions(+)
-
-diff --git a/src/libzmq.pc.in b/src/libzmq.pc.in
-index ba155a3..52a39f7 100644
---- a/src/libzmq.pc.in
-+++ b/src/libzmq.pc.in
-@@ -7,4 +7,5 @@ Name: libzmq
- Description: 0MQ c++ library
- Version: @VERSION@
- Libs: -L${libdir} -lzmq
-+Libs.private: -lstdc++
- Cflags: -I${includedir}
--- 
-2.1.4
-
diff --git a/package/zeromq/0004-allow-without-libsodium.patch b/package/zeromq/0004-allow-without-libsodium.patch
deleted file mode 100644 (file)
index 19850ba..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From c561766ab4ee4b3420b72e33fac4a75fb9194430 Mon Sep 17 00:00:00 2001
-From: Min RK <benjaminrk@gmail.com>
-Date: Mon, 16 Feb 2015 14:59:54 -0800
-Subject: [PATCH] allow `--without-libsodium`
-
-and `--with-libsodium=no` to disable linking against libsodium.
-
-Without this patch, it is not possible to disable linking with libsodium present on the default path.
-
-Backport from upstream commit
-faaf4550263395b84e6a80d3f9d7ba8816cdd714.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- configure.ac | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 194fcb2..3d5f6d6 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -257,7 +257,12 @@ esac
- # Checks for libraries
- AC_CHECK_LIB([pthread], [pthread_create])
- AC_CHECK_LIB([rt], [clock_gettime])
--AC_CHECK_LIB([sodium], [sodium_init],,AC_MSG_WARN(libsodium is needed for CURVE security))
-+
-+if test "x$with_libsodium" != "xno"; then
-+    AC_CHECK_LIB([sodium], [sodium_init],,AC_MSG_WARN(libsodium is needed for CURVE security))
-+else
-+    AC_MSG_WARN(libsodium is needed for CURVE security)
-+fi
- #
- # Check if the compiler supports -fvisibility=hidden flag. MinGW32 uses __declspec
--- 
-2.4.5
-
index 729e7ea75273e8d3339f7f11b46117a23d52355f..6c7916e96cfc970e4475c0579fad19a4c119ecbf 100644 (file)
@@ -1,2 +1,4 @@
 # Locally calculated from download (no sig, hash)
-sha256 3bc93c5f67370341428364ce007d448f4bb58a0eaabd0a60697d8086bc43342b        zeromq-4.0.5.tar.gz
+sha256 f9162ead6d68521e5154d871bac304f88857308bb02366b81bb588497a345927        zeromq-4.1.2.tar.gz
+# From http://download.zeromq.org/SHA1SUMS:
+sha1   86c17096f7f4bf46cbcd2ad242cf8fec8a7cfb7b        zeromq-4.1.2.tar.gz
index 029fab2bc7373fe3291a79680e8be0ae60b5997c..a58a6fe1cf25feeae9d803995bb9b34a469bc61b 100644 (file)
@@ -4,15 +4,13 @@
 #
 ################################################################################
 
-ZEROMQ_VERSION = 4.0.5
+ZEROMQ_VERSION = 4.1.2
 ZEROMQ_SITE = http://download.zeromq.org
 ZEROMQ_INSTALL_STAGING = YES
 ZEROMQ_DEPENDENCIES = util-linux
 ZEROMQ_LICENSE = LGPLv3+ with exceptions
 ZEROMQ_LICENSE_FILES = COPYING COPYING.LESSER
-# For 0001-tests-disable-test_fork-if-fork-is-not-available.patch
-# and 0002-acinclude.m4-make-kernel-specific-flags-cacheable.patch
-# and 0004-allow-without-libsodium.patch
+# For 0001-acinclude.m4-make-kernel-specific-flags-cacheable.patch
 ZEROMQ_AUTORECONF = YES
 
 # Assume these flags are always available. It is true, at least for