dvblast: new package
authorJulian Scheel <julian@jusst.de>
Sun, 18 Oct 2015 12:34:11 +0000 (14:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 18 Oct 2015 14:04:01 +0000 (16:04 +0200)
DVBlast is a simple and powerful MPEG-2/TS demux and streaming
application.

[Thomas:
 - add missing hash file.
 - rewrap Config.in help text
 - remove unneeded "DVBLAST_INSTALL_TARGET = YES", since this is the
   default behavior
 - pass TARGET_MAKE_ENV in the environment when calling make.
 - use TARGET_CONFIGURE_OPTS instead of just CC/LD.]

Signed-off-by: Julian Scheel <julian@jusst.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/dvblast/Config.in [new file with mode: 0644]
package/dvblast/dvblast.hash [new file with mode: 0644]
package/dvblast/dvblast.mk [new file with mode: 0644]

index c2f12f322e68e143f9caed288106069e582cf120..774674299ade7c24cb6c38f3cb19f7c6585203bd 100644 (file)
@@ -7,6 +7,7 @@ menu "Audio and video applications"
        source "package/alsa-utils/Config.in"
        source "package/aumix/Config.in"
        source "package/bellagio/Config.in"
+       source "package/dvblast/Config.in"
        source "package/dvdauthor/Config.in"
        source "package/dvdrw-tools/Config.in"
        source "package/espeak/Config.in"
diff --git a/package/dvblast/Config.in b/package/dvblast/Config.in
new file mode 100644 (file)
index 0000000..ac8b4ae
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_DVBLAST
+       bool "dvblast"
+       select BR2_PACKAGE_BITSTREAM
+       select BR2_PACKAGE_LIBEV
+       depends on !BR2_bfin  # libev
+       help
+         DVBlast is a simple and powerful MPEG-2/TS demux and
+         streaming application.
+
+         http://www.videolan.org/projects/dvblast.html
diff --git a/package/dvblast/dvblast.hash b/package/dvblast/dvblast.hash
new file mode 100644 (file)
index 0000000..198549f
--- /dev/null
@@ -0,0 +1,4 @@
+# from https://get.videolan.org/dvblast/3.0/dvblast-3.0.tar.bz2.md5
+md5 89ea9ffb16476d47b8853e52a8a3ee63 dvblast-3.0.tar.bz2
+# locally calculated
+sha256 4fc3eb2a3d3545cb76a5c515a16671d1c34fe2f5dad57b71e89bd54c14c3045e dvblast-3.0.tar.bz2
diff --git a/package/dvblast/dvblast.mk b/package/dvblast/dvblast.mk
new file mode 100644 (file)
index 0000000..11a2dc8
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# dvblast
+#
+################################################################################
+
+DVBLAST_VERSION = 3.0
+DVBLAST_SOURCE = dvblast-$(DVBLAST_VERSION).tar.bz2
+DVBLAST_SITE = https://get.videolan.org/dvblast/$(DVBLAST_VERSION)
+DVBLAST_LICENSE = GPLv2+, WTFPL
+DVBLAST_LICENSE_FILES = COPYING COPYING.WTFPL
+DVBLAST_DEPENDENCIES = bitstream libev
+
+define DVBLAST_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+define DVBLAST_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) PREFIX=/usr install
+endef
+
+$(eval $(generic-package))