sqlcipher: fix build for xtensa
authorBaruch Siach <baruch@tkos.co.il>
Thu, 23 Jan 2014 09:53:52 +0000 (11:53 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 23 Jan 2014 11:45:33 +0000 (12:45 +0100)
The sqlcipher package generates libraries that are too large for the xtensa
default placement of literals in a dedicated section. Use
-mtext-section-literal to place literals in the text section.

Fixes:
http://autobuild.buildroot.net/results/921/92116c2837e4c449919e7a0ab9aebd6abb1cbaf1/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sqlcipher/sqlcipher.mk

index 6130870bba1f434b1964f83cd3623c9ce8c87dab..ace5ce8f55c82e9f729b4faac96913447dd49371 100644 (file)
@@ -32,6 +32,10 @@ ifeq ($(BR2_PACKAGE_SQLCIPHER_STAT3),y)
 SQLCIPHER_CFLAGS += -DSQLITE_ENABLE_STAT3
 endif
 
+ifeq ($(BR2_xtensa),y)
+SQLCIPHER_CFLAGS += -mtext-section-literals
+endif
+
 ifeq ($(BR2_PACKAGE_SQLCIPHER_READLINE),y)
 SQLCIPHER_DEPENDENCIES += ncurses readline
 SQLCIPHER_CONF_OPT += --with-readline-inc="-I$(STAGING_DIR)/usr/include"