boot/uboot: Fix kconfig to use $(BR2_MAKE)
authorBrandon Maier <brandon.maier@rockwellcollins.com>
Tue, 4 Aug 2020 19:00:05 +0000 (14:00 -0500)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 6 Aug 2020 20:41:31 +0000 (22:41 +0200)
U-Boot must use $(BR2_MAKE) as it uses a Make feature from v4.0. We
already use $(BR2_MAKE) in the BUILD_CMDS, but the kconfig commands
still uses $(MAKE). Without this fix, building U-Boot with kconfig will
fail with the following cryptic error.

> Makefile:37: *** missing separator.  Stop.

Signed-off-by: Brandon Maier <brandon.maier@rockwellcollins.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
boot/uboot/uboot.mk

index 8a09969de1da3d30a28a615a80e74e0027327f53..1831466780eae5b1f273a43673974f1e6102bfcc 100644 (file)
@@ -16,6 +16,7 @@ UBOOT_INSTALL_IMAGES = YES
 
 # u-boot 2020.01+ needs make 4.0+
 UBOOT_DEPENDENCIES = $(BR2_MAKE_HOST_DEPENDENCY)
+UBOOT_MAKE = $(BR2_MAKE)
 
 ifeq ($(UBOOT_VERSION),custom)
 # Handle custom U-Boot tarballs as specified by the configuration
@@ -257,7 +258,7 @@ UBOOT_POST_PATCH_HOOKS += UBOOT_FIXUP_LIBFDT_INCLUDE
 ifeq ($(BR2_TARGET_UBOOT_BUILD_SYSTEM_LEGACY),y)
 define UBOOT_CONFIGURE_CMDS
        $(TARGET_CONFIGURE_OPTS) \
-               $(BR2_MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
+               $(UBOOT_MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
                $(UBOOT_BOARD_NAME)_config
 endef
 else ifeq ($(BR2_TARGET_UBOOT_BUILD_SYSTEM_KCONFIG),y)
@@ -294,7 +295,7 @@ define UBOOT_BUILD_CMDS
                cp -f $(UBOOT_CUSTOM_DTS_PATH) $(@D)/arch/$(UBOOT_ARCH)/dts/
        )
        $(TARGET_CONFIGURE_OPTS) \
-               $(BR2_MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
+               $(UBOOT_MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
                $(UBOOT_MAKE_TARGET)
        $(if $(BR2_TARGET_UBOOT_FORMAT_SD),
                $(@D)/tools/mxsboot sd $(@D)/u-boot.sb $(@D)/u-boot.sd)