fio: new package
authorEzequiel Garcia <ezequiel.garcia@free-electrons.com>
Wed, 30 Oct 2013 15:22:25 +0000 (12:22 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 25 Dec 2013 15:44:13 +0000 (16:44 +0100)
[Thomas: add largefile and thread dependencies, bump to version 2.1.4,
 use upstream Git instead of Debian tarballs, adjust license
 information]

Signed-off-by: Ezequiel Garcia <ezequiel.garcia@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/fio/Config.in [new file with mode: 0644]
package/fio/fio.mk [new file with mode: 0644]

index fe31cd2b0a58877393ff1b7822675a7b410d53fa..76f8d4f82fe6cdb5d7e76f9961bf0f39cfa18faa 100644 (file)
@@ -47,6 +47,7 @@ source "package/dmalloc/Config.in"
 source "package/dropwatch/Config.in"
 source "package/dstat/Config.in"
 source "package/duma/Config.in"
+source "package/fio/Config.in"
 source "package/gdb/Config.in"
 source "package/iozone/Config.in"
 source "package/kexec/Config.in"
diff --git a/package/fio/Config.in b/package/fio/Config.in
new file mode 100644 (file)
index 0000000..deff12c
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_FIO
+       bool "fio"
+       depends on BR2_USE_MMU # fork()
+       depends on BR2_LARGEFILE
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       help
+         fio is an I/O tool meant to be used both for benchmark
+         and stress/hardware verification.
+
+         http://git.kernel.dk/?p=fio.git;a=summary
+
+comment "fio needs a toolchain w/ largefile, threads"
+       depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/fio/fio.mk b/package/fio/fio.mk
new file mode 100644 (file)
index 0000000..f9a690e
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# fio
+#
+################################################################################
+
+FIO_VERSION = fio-2.1.4
+FIO_SITE = git://git.kernel.dk/fio.git
+FIO_LICENSE = GPLv2 + special obligations
+FIO_LICENSE_FILES = LICENSE
+
+define FIO_CONFIGURE_CMDS
+       (cd $(@D); ./configure --cc="$(TARGET_CC)" --extra-cflags="$(TARGET_CFLAGS)")
+endef
+
+define FIO_BUILD_CMDS
+       $(MAKE) -C $(@D)
+endef
+
+define FIO_INSTALL_TARGET_CMDS
+       $(INSTALL) -D $(@D)/fio $(TARGET_DIR)/usr/bin/fio
+endef
+
+$(eval $(generic-package))