rxvt: don't use getpt()
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 22 Dec 2008 22:10:35 +0000 (22:10 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 22 Dec 2008 22:10:35 +0000 (22:10 -0000)
uClibc can be (and per default is) configured to not implement the glibc
function getpt(3), so use the non-getpt rxvt configuration.

package/rxvt/rxvt-2.7.5-include.patch [new file with mode: 0644]
package/rxvt/rxvt.mk

diff --git a/package/rxvt/rxvt-2.7.5-include.patch b/package/rxvt/rxvt-2.7.5-include.patch
new file mode 100644 (file)
index 0000000..4ad51bb
--- /dev/null
@@ -0,0 +1,17 @@
+uClibc doesn't have <sys/stropts.h>
+---
+ src/init.h |    1 -
+ 1 file changed, 1 deletion(-)
+
+Index: rxvt-2.7.5/src/init.h
+===================================================================
+--- rxvt-2.7.5.orig/src/init.h
++++ rxvt-2.7.5/src/init.h
+@@ -16,7 +16,6 @@
+ #if defined(PTYS_ARE_PTMX) && !defined(__CYGWIN32__)
+ # include <sys/resource.h>    /* for struct rlimit */
+-# include <sys/stropts.h>     /* for I_PUSH */
+ # define _NEW_TTY_CTRL                /* to get proper defines in <termios.h> */
+ #endif
index 2cf1fad89980cb75695ff613faf7d3c1e37ac1ef..e28d7dfc7a79b1484dabc40f6a480474de50bcd9 100644 (file)
@@ -42,7 +42,7 @@ $(RXVT_DIR)/.configured: $(RXVT_DIR)/.unpacked
        (cd $(RXVT_DIR); rm -rf config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
                $(TARGET_CONFIGURE_ARGS) \
-               rxvt_cv_ptys=GLIBC \
+               rxvt_cv_ptys=USG \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \