package/polkit: install polkit.loc to HOST_DIR
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 20 Aug 2021 20:13:13 +0000 (22:13 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 20 Aug 2021 21:00:20 +0000 (23:00 +0200)
Fix added by commit c20d31baf471daeeec50d62cb8baa79bac06fa51 is
incomplete as polkit.loc must also be added to
$(HOST_DIR)/share/gettext/its

Additionally, the destination path for "$(INSTALL) -D" must be a
fully-qualified filename, not just the destination directory.

Fixes:
 - http://autobuild.buildroot.org/results/170e4802b7b4e8e7dafa95ade549e8fd05e43bfd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: dest must be a filename, not a directory]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/polkit/polkit.mk

index 23adb534d05768e7a252520fa76929dc1e1f0b48..3a8c442dbb43799b51b9e5ec21e5713e32c782f2 100644 (file)
@@ -41,11 +41,13 @@ else
 POLKIT_CONF_OPTS += --with-authfw=shadow
 endif
 
-# polkit.its is needed for gvfs and must be installed in $(HOST_DIR)
+# polkit.{its,loc} are needed for gvfs and must be installed in $(HOST_DIR)
 # and not $(STAGING_DIR)
 define POLKIT_INSTALL_ITS
        $(INSTALL) -D -m 644 $(@D)/data/polkit.its \
-               $(HOST_DIR)/share/gettext/its
+               $(HOST_DIR)/share/gettext/its/polkit.its
+       $(INSTALL) -D -m 644 $(@D)/data/polkit.loc \
+               $(HOST_DIR)/share/gettext/its/polkit.loc
 endef
 POLKIT_POST_INSTALL_TARGET_HOOKS += POLKIT_INSTALL_ITS