package/umtprd: new package
authorPaul Cercueil <paul@crapouillou.net>
Wed, 13 Nov 2019 11:21:36 +0000 (12:21 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 19 Nov 2019 16:30:48 +0000 (17:30 +0100)
uMTP-Responder is a lightweight USB Media Transfer Protocol (MTP)
responder daemon for GNU/Linux.

Signed-off-by: Paul Cercueil <paul@crapouillou.net>
[Thomas: license is GPL-3.0+]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/umtprd/Config.in [new file with mode: 0644]
package/umtprd/umtprd.hash [new file with mode: 0644]
package/umtprd/umtprd.mk [new file with mode: 0644]

index 054f83ce5e83dc7698f16003975af27bd06ed72d..b1a20eaebeaa52c5a591e5fe863bcf872d216ded 100644 (file)
@@ -1807,6 +1807,7 @@ F:        package/yavta/
 N:     Paul Cercueil <paul@crapouillou.net>
 F:     package/libiio/
 F:     package/lightning/
+F:     package/umtprd/
 
 N:     Pedro Aguilar <paguilar@paguilar.org>
 F:     package/libunistring/
index fd30562ea5519758199200d2ea39751cbd9fc28e..48c5bcec399d4d4bfb6ba0fe1435176fb33d0347 100644 (file)
@@ -551,6 +551,7 @@ endmenu
        source "package/udev/Config.in"
        source "package/udisks/Config.in"
        source "package/uhubctl/Config.in"
+       source "package/umtprd/Config.in"
        source "package/upower/Config.in"
        source "package/usb_modeswitch/Config.in"
        source "package/usb_modeswitch_data/Config.in"
diff --git a/package/umtprd/Config.in b/package/umtprd/Config.in
new file mode 100644 (file)
index 0000000..24bf119
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_UMTPRD
+       bool "umtprd"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_15
+       help
+         Lightweight USB MTP responder daemon for GNU/Linux
+
+         https://github.com/viveris/uMTP-Responder
+
+comment "umtprd needs a toolchain w/ threads, headers >= 3.15"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_15
diff --git a/package/umtprd/umtprd.hash b/package/umtprd/umtprd.hash
new file mode 100644 (file)
index 0000000..168b19e
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256 e1301bdd89170cc2c679446c1cc5873feaacd061bf0ab547fc0a11670bae9163        umtprd-1.0.0.tar.gz
+sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903        LICENSE
diff --git a/package/umtprd/umtprd.mk b/package/umtprd/umtprd.mk
new file mode 100644 (file)
index 0000000..63faae4
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# umtprd
+#
+################################################################################
+
+UMTPRD_VERSION = 1.0.0
+UMTPRD_SITE = https://github.com/viveris/uMTP-Responder/archive
+UMTPRD_LICENSE = GPL-3.0+
+UMTPRD_LICENSE_FILES = LICENSE
+
+define UMTPRD_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define UMTPRD_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/umtprd $(TARGET_DIR)/usr/sbin/umtprd
+endef
+
+$(eval $(generic-package))