socat: security bump to version 2.0.0-b7
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 10 Mar 2014 19:34:05 +0000 (16:34 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 11 Mar 2014 10:48:04 +0000 (11:48 +0100)
Fixes CVE-2014-0019.
Also rename patch according to policy.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/socat/socat-001-no-documentation.patch [new file with mode: 0644]
package/socat/socat-no-documentation.patch [deleted file]
package/socat/socat.mk

diff --git a/package/socat/socat-001-no-documentation.patch b/package/socat/socat-001-no-documentation.patch
new file mode 100644 (file)
index 0000000..ce088df
--- /dev/null
@@ -0,0 +1,37 @@
+socat: disable documentation build/installation
+
+The documentation generation process requires a special yold2man
+program, for which we don't have a package in Buildroot. Since we
+generally don't care much about documentation of packages, just adjust
+the package Makefile.in to not build/install its documentation.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile.in
+===================================================================
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -93,7 +93,7 @@
+       Config/Makefile.Cygwin-1-5-25 Config/config.Cygwin-1-5-25.h \
+       Config/Makefile.MacOSX-10-5 Config/config.MacOSX-10-5.h
+-all: progs doc
++all: progs
+ scmclean: gitclean
+@@ -136,13 +136,11 @@
+ strip: progs
+       strip $(PROGS)
+-install: progs $(srcdir)/doc/socat.1
++install: progs
+       mkdir -p $(DESTDIR)$(BINDEST)
+       $(INSTALL) -m 755 socat $(DESTDIR)$(BINDEST)
+       $(INSTALL) -m 755 procan $(DESTDIR)$(BINDEST)
+       $(INSTALL) -m 755 filan $(DESTDIR)$(BINDEST)
+-      mkdir -p $(DESTDIR)$(MANDEST)/man1
+-      $(INSTALL) -m 644 $(srcdir)/doc/socat.1 $(DESTDIR)$(MANDEST)/man1/
+ uninstall:
+       rm -f $(DESTDIR)$(BINDEST)/socat
diff --git a/package/socat/socat-no-documentation.patch b/package/socat/socat-no-documentation.patch
deleted file mode 100644 (file)
index ce088df..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-socat: disable documentation build/installation
-
-The documentation generation process requires a special yold2man
-program, for which we don't have a package in Buildroot. Since we
-generally don't care much about documentation of packages, just adjust
-the package Makefile.in to not build/install its documentation.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/Makefile.in
-===================================================================
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -93,7 +93,7 @@
-       Config/Makefile.Cygwin-1-5-25 Config/config.Cygwin-1-5-25.h \
-       Config/Makefile.MacOSX-10-5 Config/config.MacOSX-10-5.h
--all: progs doc
-+all: progs
- scmclean: gitclean
-@@ -136,13 +136,11 @@
- strip: progs
-       strip $(PROGS)
--install: progs $(srcdir)/doc/socat.1
-+install: progs
-       mkdir -p $(DESTDIR)$(BINDEST)
-       $(INSTALL) -m 755 socat $(DESTDIR)$(BINDEST)
-       $(INSTALL) -m 755 procan $(DESTDIR)$(BINDEST)
-       $(INSTALL) -m 755 filan $(DESTDIR)$(BINDEST)
--      mkdir -p $(DESTDIR)$(MANDEST)/man1
--      $(INSTALL) -m 644 $(srcdir)/doc/socat.1 $(DESTDIR)$(MANDEST)/man1/
- uninstall:
-       rm -f $(DESTDIR)$(BINDEST)/socat
index df60961c82becc566aa0f4daa3884ee2c0279a45..6ae67a9f53226aa5710e550e665635f52c2a2b25 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-SOCAT_VERSION = 2.0.0-b6
+SOCAT_VERSION = 2.0.0-b7
 SOCAT_SOURCE = socat-$(SOCAT_VERSION).tar.bz2
 SOCAT_SITE = http://www.dest-unreach.org/socat/download/
 SOCAT_LICENSE = GPLv2