coreutils: expand list of files moved from /usr/bin to /bin
authorCarlos Santos <casantos@datacom.ind.br>
Thu, 12 Oct 2017 23:33:32 +0000 (20:33 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 1 Jan 2018 14:58:58 +0000 (15:58 +0100)
BusyBox installs kill, link, mktemp, nice and printenv on /bin, so
ensure that coreutils replaces them.

Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/coreutils/coreutils.mk

index 6a8a31b06140b578d8ad2dd5f6a70e52460a7831..8259f42f4a6adff97e4394738ee4b66004765521 100644 (file)
@@ -56,8 +56,8 @@ COREUTILS_CONF_ENV = ac_cv_c_restrict=no \
        INSTALL_PROGRAM=$(INSTALL)
 
 COREUTILS_BIN_PROGS = cat chgrp chmod chown cp date dd df dir echo false \
-       ln ls mkdir mknod mv pwd rm rmdir vdir sleep stty sync touch true \
-       uname join
+       kill link ln ls mkdir mknod mktemp mv nice printenv pwd rm rmdir \
+       vdir sleep stty sync touch true uname join
 
 # If both coreutils and busybox are selected, make certain coreutils
 # wins the fight over who gets to have their utils actually installed.