gvfs: enable gphoto2
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 19 Oct 2018 20:13:15 +0000 (22:13 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 20 Oct 2018 16:04:48 +0000 (18:04 +0200)
Enable gphoto2 if libgphoto2 and libgudev are available

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gvfs/gvfs.mk

index e34033d5c73178aa252dd9d9fba223d85fc597cf..0fdb9e1267aa61d37db752079d7560ff63976be9 100644 (file)
@@ -23,7 +23,6 @@ GVFS_CONF_OPTS = \
        --disable-gdu \
        --disable-goa \
        --disable-google \
-       --disable-gphoto2 \
        --disable-keyring \
        --disable-libmtp \
        --disable-udisks2
@@ -99,6 +98,13 @@ else
 GVFS_CONF_OPTS += --disable-afp
 endif
 
+ifeq ($(BR2_PACKAGE_LIBGPHOTO2)$(BR2_PACKAGE_LIBGUDEV),yy)
+GVFS_DEPENDENCIES += libgphoto2 libgudev
+GVFS_CONF_OPTS += --enable-gphoto2
+else
+GVFS_CONF_OPTS += --disable-gphoto2
+endif
+
 ifeq ($(BR2_PACKAGE_LIBGTK3),y)
 GVFS_CONF_OPTS += --enable-gtk
 GVFS_DEPENDENCIES += libgtk3