package/mutt: add gnutls optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 23 Dec 2020 10:59:50 +0000 (11:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Dec 2020 17:23:01 +0000 (18:23 +0100)
gnutls is an optional dependency since version 1.5.7 and
https://gitlab.com/muttmua/mutt/-/commit/457d70d6b10860bae084837024eb34aa3bfbc5fa

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mutt/mutt.mk

index 4e140045775fb91f03a03748bdbe2dfdc3b1bda2..67fc4ed8384dbc170665af9ac533c84ec20b872e 100644 (file)
@@ -46,12 +46,23 @@ endif
 ifneq ($(BR2_PACKAGE_MUTT_IMAP)$(BR2_PACKAGE_MUTT_POP3),)
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 MUTT_DEPENDENCIES += openssl
-MUTT_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
+MUTT_CONF_OPTS += \
+       --without-gnutls \
+       --with-ssl=$(STAGING_DIR)/usr
+else ifeq ($(BR2_PACKAGE_GNUTLS),y)
+MUTT_DEPENDENCIES += gnutls
+MUTT_CONF_OPTS += \
+       --with-gnutls=$(STAGING_DIR)/usr \
+       --without-ssl
 else
-MUTT_CONF_OPTS += --without-ssl
+MUTT_CONF_OPTS += \
+       --without-gnutls \
+       --without-ssl
 endif
 else
-MUTT_CONF_OPTS += --without-ssl
+MUTT_CONF_OPTS += \
+       --without-gnutls \
+       --without-ssl
 endif
 
 ifeq ($(BR2_PACKAGE_SQLITE),y)